Quantcast
Jump to content

  • Do you own an ATV, UTV or SxS? Join our Community Forum!

    QUADCRAZY ATV Community and Forum are FREE to join! We keep our ATV, UTV, and SxS forums clean and user friendly. All first time posters in our forums will have to wait to have their content reviewed and approved. Once your first ten posts are approved, you will no longer need to go through a forum post approval process. To bypass the approval process with immediate access and a NO ADS experience in our ATV, SxS, and UTV forums, consider subsribing to a Premium Membership

Quad not running smoothly...


Recommended Posts

I recently moved my ATV from Pennsylvania (low elevation) to Denver (high elevation). As soon as I took it off the truck, it wouldn't stay running. It runs if I give it a little gas, but as soon as I let off the throttle, it stalls out and dies. It ran fine in PA. Think it could be because of the thinner air? Where do I start with fixing it?

Thanks!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By GrizzlyRider
      Does anyone own a Massimo MSA450 ATV Quicksand oe see these? It looks like Tractor Supply sells them for $6K. It looks pretty solid, has independent rear suspension. 
      Here's the listing on tractor supply:

       
      Massimo website says
      Massimo MSA 450 - our powerful, single-cylinder, 4-stroke ATV. With 25 horsepower and a top speed of 42mph, this middle-weight ATV offers Hi and Low forward gears, neutral, and reverse, along with selectable 4WD. Boasting 11 inches of ground clearance and 25-inch tires, the MSA 450 tackles any challenge while carrying a load of up to 350lbs and towing up to 800lbs.
      352cc 25 HP EFI 4 stroke engine On demand 4WD with 25 in. AT tires Front & Rear Rack Hand Guards Front Bumper
       
       
    • By Ajmboy
      So we are almost a month into winter and I've been so busy working on my house that up until today, I didn't realize that we just haven;t gotten any real snow yet to warrant putting the plow on my grizzly. So that got me thinking, what are the latest plows out there and what ATV plows are the best? I've got 2 snow plows for my grizzly, a quadboss pile driver atv plow set up and a snowsport ATV plow. They are both a bit dated now and I tend to stick with the snowsport due to ease of use and I just like it so much. So if you have a plow on your ATV, please let us know what it is and post a picture with your atv/plow would be awesome. Would also like to know what you like and dislike about it.
      This is back a while when I did a write up on these 2 plows.... in 2009 I got the snowsport and in 2012 I got the quadboss.
       
    • By Starsat
      The choke lever doesn't stay in position on my 2001 Yamaha Kodiak.  The model is YFM 400.  I have to hold the lever to the choke position manually for some reason.  Any Ideas as to why?
    • By Bobbywolf
      I am working on a basket case for a friend.  It is a 98 Big Bear (YFM350FWB).  It came with a parts machine which is a 96, which I am coming to find out is VERY different from his machine.
       
      Anyway, first thing is first.  I checked compression, 150psi.  Valves are set correctly, and the engine is in time.  I cleaned the carb, and there was some junk in the passages.  It is a chinese carb, which I figured from the lack of markings or lettering altogether.
       
      The bike runs.  It idles ok, but breaks up badly under acceleration.  Pulling a new spark plug shows it is running lean.  White strap, with no black whatsoever.  So I have the carb adjusted with the mixture screw out way too much (about 5 turns), and the diaphragm needle lifted to the top slot.  It is still not getting enough fuel (or too much air).  It backfires through the carb, and cannot get above idle without carrying on.  The carb boot is in good shape, so it isn't pulling any air there.  I did test this as well by spraying ether around the boot when running, looking for intake leaks.
       
      Anything big I am missing here?  I am starting to believe that this chinese carb is the issue.  This quad came with the original carb, which I would like to rebuild and use, but the mixture screw is totally stuck, and stripped way down in its recess.  
       
      Thanks for any assistance.
    • By WyattLemke25
      Working on a 2016 Sportsman 570 and it has a new battery and spark plug. No codes, fuses all look good. It cranks for a while and when it starts it will only run for a few seconds before stalling. At one point it was running at 3000 rpm with no throttle input, then it dies. Not sure where to look besides messing with the throttle cable, so suggestions are appreciated, Thanks. 
  • Similar Tagged Forum Content

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...