Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

zacdog

help please!!!! Gas tank vent tube

Recommended Posts

Hey guys. I have a 2004 Polaris PRedator and the piece that connects the vent tube to the gas cap came off. so the tube wont just go into the hole. Im supposed to be going to ride tomorrow so is it safe to ride it without the tube? or if not is there something I can do for a quick fix?

Share this post


Link to post
Share on other sites


zacdog,

I'll give you my take on your problem: I think you are talking about the nipple that the hose connects to, on your cap.

It should be fine; no gas should come out if the vent is working properly; there is a valve in the cap that separates vapor from liquid, only allowing vapor to vent from the tank.

But in saying that; I wouldn't let the quad out in the rain or pressure wash it. Water may enter the hole in the cap, where the vent hose should be.

DON'T plug the hole! Your system needs that to be open to the atmosphere.

Share this post


Link to post
Share on other sites

Nice of you to respond, and with solid advise to boot. However, he posted this on July 29th, so "tomorrow" was a month ago. I suspect he has probably replaced the gas cap by now.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Ajmboy
      Got my Yamaha Grizzly buttoned up finally and went for a quick 2 hour ride in the power lines with my neighbor, who has a Yamaha Kodiak. We have access from his yard, which is nice. Was a beautiful day today to get out and will try to go more often. Ran into two other quad riders with a sportsman and I think grizzly. Also ran into a dirt bike rider. 😎




       
    • By colin james
      View File 2018/2019 Polaris Sportsman XP 850/1000 Service Manual
      This is the factory service manual for the 2018/2019 Polaris Sportsman XP 850/1000
      Submitter colin james Submitted 08/01/2019 Category Polaris ATV  
    • By Jeremy Morris
      If you're getting that pesky leaky seal on the pinion of your front differential and the pinion has allot of play, polaris won't sell the bushing needed to repair it properly without having to shell out big bucks for the complete ring and pinion kit. 
      I have a kit with an upgraded bushing, Japanese made bearing and USmade seal
      50 shipped in the US and 55 to Canada

    • By Chase Cook
      I have a Polaris sportsman 500 and I just replace the piston in rings and head gaskets on it and I made sure the timing was exactly right it's getting gas and fire but it still won't start. It sounds like it has low compression but at the same time it sucks in air pretty good from the intake. Also the valves are adjusted to spec. It did start the first time I installed the Piston and Rings but it only stayed running for 5 seconds with starting fluid and then it shut off and then I tried to turn on the next day and it didn't do nothing and I've been going at it for three weekends now and it still ain't doing nothing. I wonder if i set the timing off a little or a lot if it would start up, because I inline the crankshaft sprocket with the crankcase timing line like it said in a manual and the two points on top of the cam sprocket to top dead center of the piston. I even took the spark plug out and stuck a camera light in there to make sure it was top dead center and it still won't do anything. AlsoI drain the carburetor some and shut d fuel petcock off to see if it was getting too much gas and that still isn't the problem. And where I live all the darn mechanics that work on Polaris ATVs are booked for two weeks which sucks and I need hope immediately or I'm just going to set the ATV on fire because I'm getting very frustrated with this crappy brand. Every other name brand ATV I worked on I got it running right and I replace the piston, rings and everything etc, and they started up fine. But this is starting to get very frustrated and I don't know who to talk to who had this problem before, who "don't have to come look at it". Cuz when they say that that means you're not going to come look at it until 2-4 Weeks later because there booked, which I don't have time for. Living in northern part of Florida sucks.
  • Similar Tagged Content

    • By Connie Johnson Donald Hudson
      Smells like gas in the oil ... Also, recently replaced belt, new BT does not have grooves on both sides, does that pose a problem?  Also just bought and replaced new carburetor, never has it idled better, but give it gas and it backfires very loudly!
    • By LTZ-Zach
      So i was riding the other day and my quad randomly shut off. It started back up and ran completely fine for a little while and then it started idling terribly.
      I cleaned the carb and changed all the jets and everything except the float due to the rebuild kit not coming with one and it actually runs worse then it did before.
      It will run and idle decent now but when I give it gas it dies.
      Does anybody know what could be wrong?
      I also changed the spark plug and air filter along with the oil and oil filter.
       
    • By toonces
      What's a good fuel stabilizer to deal with ethanol in gas?
    • By jpalidar
      I have a cannondale cannibal with a 450 kit in it. I just recently switched up the fuel pressure line. Now when I start it or attempt to start it gas pours out of something when I hit the electric start ? can anyone help diagnose the problem? Thanks!
    • By raybob
      I have a prairie 650 there is oil coming out of the tube that goes to the air box a lot of oil can someone help. Ray
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...