Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

charles9403

2004 Honda Rancher TRX400 Battery

Recommended Posts

I bought a new after market battery for my 2004 Honda Rancher TRX400 a few months ago. it started and ran fine. I tried to crank it today and the power would not even come on. I took the battery out and took it to the parts store and they tested it and said it was good and just needed to be charged. They charged it, and I put it back in and hooked it up. It still does not get any power and lights dont even come on. Does anyone known what the problem may be??? Stumped in Mississippi

Share this post


Link to post
Share on other sites


Welcome to QUADCRAZY. Check all of your connections. Take a tester out and start testing for power outside the battery.

* Chaged your thread title, you had put your username for a title. :biggrin:

Share this post


Link to post
Share on other sites

Start at the battery checking both pos (+) and ground (-) making sure all connections are tight and clean. The gounnd should go to the frame close by, then follow the pos(+) cable checking for tightness and cleaning all connnections if it goes into a solenoid figure how to energize it to keep following the path every direction it goes. This sounds like a of checking but is the only way to find where the power isn't going.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Red1
      Anyone know a good place for parts/plastics? I've seen junk for sale on eBay and overpriced. 
       
      I need the left side cover (triangle plastic) for my 1985 250es

    • By Randy1951
      Quad starts fine and revs fine in my back yard. On a test ride it falters badly. No power. I have cleaned and rebuilt the carb, cleaned the fuel tank, installed new fuel filter, changed fuel line and cleaned the air filter. Any help would be appreciated.
    • By Erik Plug
      Hi all,
       
      Picked up my first Brute Force yesterday. What should have been an awesome afternoon of riding turn a bit into a deception. As I was unable to really take it out for a test drive at the shop, I decided to buy it and agreed that I would take the test drive at home. 
      When giving full throttle I noticed that the Brute was choking and lost all of its powers. Faulty fuel pump most likely. 
      Called the shop and the are coming to pick it up and repair it and bring it back. Good service. Nevertheless feels a bit sour in the mouth as I was told it was a 100% good. 
      Need to have some patience I now before I can really start riding. 
      Cheers,
      Erik
    • By Ajmboy
      Got my Yamaha Grizzly buttoned up finally and went for a quick 2 hour ride in the power lines with my neighbor, who has a Yamaha Kodiak. We have access from his yard, which is nice. Was a beautiful day today to get out and will try to go more often. Ran into two other quad riders with a sportsman and I think grizzly. Also ran into a dirt bike rider. 😎




       
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...