Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

shasenplaugh

1997 Yamaha Kodiak 400 Rough Running

Recommended Posts

My 1997 Kodiak 400 just suddenly started running really bad. It sounds great in neutral, but as soon as you put it into gear it starts bogging down and cutting out real bad. I did find a hole in the intake and I replaced it, but that didn't help at all. Does anyone have any suggestions? I did take the carb apart and cleaned it and noticed that that wasn't the first time it had been apart. Thanks in advance for any help.

Edited by shasenplaugh

Share this post


Link to post
Share on other sites


Welcome to QUADCRAZY! Did you check the float operation when you cleaned it? Might need a rebuild. May be fuel starving.

* Edited thread title, added full year and issue.

Share this post


Link to post
Share on other sites

Ya, the float looked fine, but there was some other questionable things in it, but then again I don't know much about the guts of a carberator. It actually seems more like it's being constantly flooded and you can smell the gas. But again everything sounds fine in neutral. Even revving it up it sounds good. It's just when you put it in gear.

Edited by shasenplaugh

Share this post


Link to post
Share on other sites

If there is a reverse rev limiter on that machine, it could be assed up, if the machine thinks it is in reverse somehow, this limiter may be kicking in. Other possibilities could be weak spark, improper valve adjustment, or some kind of carb problem. I would check all the simple basic stuff first, try a new plug, check the valves, timing etc... Also, check to see if the machine has a rev limiter that could be getting activated when you engage the forward gears, try to locate a sensor or switch that lets the machine know when it is in reverse. If you find anything, try to bypass the rev limiter somehow and see if that helps. I would recommend getting a repair manual, finding these things will be alot easier with one, they are good to have anyway.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

  • Similar Tagged Content

    • By Wali
      I was riding my 400ex one day and when i shut it off to put it in the garage i tried to start it put again to drive it into the garge and it wouldnt start.I put a compression tester on it and its like 30 psi with out throttle and 0 psi WITH THROTTLE.
      when i put my finger over the hole it fell likes its pulling my finger in more then its pushing it out 
       
      Has good spark.When i took it into the shop the said it had 1oz of oil in it and a tiny pit of metal shaving(TINY BIT LIKE 30 flakes)
      When i try to pull start (push start/roll start) it made a not normal sound  and wouldnt stay running.
      If my bottom end is blow why would it still turn over fine,
      Are my valves siezed or not working properly 
      or is my timing off causeing valves to not open in correct order with fire 
      PLEASE HELP all help is appreciated 
    • By Hunter Aldridge
      Some times I get spark some times not can ride then it just dies and wont get spark it has new cdi box and stator but I don't know if it has the pickup coil I'm at a loss
    • By William Sims
      I have a 400 4by4 ,2005 green model,
      wounding how many different CDI boxes will work on it
       
    • By jerry houston
      Eiger 400 Suzuki runs fine Cook-Out joke face off the handlebars put it back on and will not start now will crank no no spark
    • By colin james
      View File 2012-2014 Polaris Sportsman 400 HD Service Manual
      This the factory service manual for the 2012- 2014 sportsman 400 hd service manual 
      Submitter colin james Submitted 02/08/2019 Category Polaris ATV  
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...