Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

kbsparky

1995 Kodiak 400 carb issues

Recommended Posts

I have a 95 kodiak 400 it starts and runs at idle and top end but in the mid-range it spits and backfires. I have put a rebuild kit in it and also the diaphram on the side to no avail.Still does the same thing.

Am looking for a carb but cant find one. Did find one from a 350 warrior but not sure if it will fit. Any help would be greatly appreciated.:aargh:

Share this post


Link to post
Share on other sites


An update : I got it to run good at idle and in the mid range pretty good at top end but it seams to run out of gas at top end .I have the float set at aprox. 1/2" and have noticed gas coming out of the (guess its a vent hole) on the air box side of the carb when sitting not running it keeps flowing out of this hole . I have tried different float settings and this problem keeps comimng back. ANY help would be great.....

Share this post


Link to post
Share on other sites

Warning - i know nothing about carbs im an EFI person. But i read a few threads were leaking fuel was caused by a needle not seating properly. You rebuilt the carb correct? Did you rejet it? Maybe there is a lil gook holding it open

Sent from my SGH-T959V using Tapatalk

Share this post


Link to post
Share on other sites

Yes I belive I did it correctly ,the jets that came in the kit were not the right size so i have the origenal jets in. I am not sure about the plastic main nozzle tube thinking it may be cracked? The fuel seams to seap out with the machine not running ,it comes out through the vent hole on the airbox side of the carb and is fine when it is running .Does seam to be running lean maybe float to tight.

Share this post


Link to post
Share on other sites

"The fuel seams to seap out with the machine not running ,it comes out through the vent hole on the airbox side of the carb and is fine when it is running .Does seam to be running lean maybe float to tight".

Ok, here is what I see, you do not leak gas when running cause the quad is using the gas, it over fills when not running cause you are not using the gas for the motor...end result, check the float, it is sticking allowing gas to build up and overflow.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Aleksandr Boreesenko
      doesn't idle at times but sometimes when it does as soon as I touch the throttle it just shuts off, what could possibly be the problem? I thank you very much for any help, Thanks.
    • By Ajmboy
      Got my Yamaha Grizzly buttoned up finally and went for a quick 2 hour ride in the power lines with my neighbor, who has a Yamaha Kodiak. We have access from his yard, which is nice. Was a beautiful day today to get out and will try to go more often. Ran into two other quad riders with a sportsman and I think grizzly. Also ran into a dirt bike rider. 😎




       
    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
    • By basmn
      View File Yamaha Kodiak 450 YFM450FAR Service Manual
      Yamaha Kodiak 450 YFM450FAR Service Manual
      got it for free so i thought i would share
      Submitter basmn Submitted 10/17/2018 Category Yamaha ATV  
  • Similar Tagged Content

    • By Wali
      I was riding my 400ex one day and when i shut it off to put it in the garage i tried to start it put again to drive it into the garge and it wouldnt start.I put a compression tester on it and its like 30 psi with out throttle and 0 psi WITH THROTTLE.
      when i put my finger over the hole it fell likes its pulling my finger in more then its pushing it out 
       
      Has good spark.When i took it into the shop the said it had 1oz of oil in it and a tiny pit of metal shaving(TINY BIT LIKE 30 flakes)
      When i try to pull start (push start/roll start) it made a not normal sound  and wouldnt stay running.
      If my bottom end is blow why would it still turn over fine,
      Are my valves siezed or not working properly 
      or is my timing off causeing valves to not open in correct order with fire 
      PLEASE HELP all help is appreciated 
    • By Hunter Aldridge
      Some times I get spark some times not can ride then it just dies and wont get spark it has new cdi box and stator but I don't know if it has the pickup coil I'm at a loss
    • By William Sims
      I have a 400 4by4 ,2005 green model,
      wounding how many different CDI boxes will work on it
       
    • By jerry houston
      Eiger 400 Suzuki runs fine Cook-Out joke face off the handlebars put it back on and will not start now will crank no no spark
    • By colin james
      View File 2012-2014 Polaris Sportsman 400 HD Service Manual
      This the factory service manual for the 2012- 2014 sportsman 400 hd service manual 
      Submitter colin james Submitted 02/08/2019 Category Polaris ATV  
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...