Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

chembree

2005 polaris predator 500 troy lee edition

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Cj Winds
      I have a 2005 Yamaha Kodiak 400 Automatic. It has an oil leak inside clutch cover. The middle gear has two oil seals, the front seal is leaking engine oil into clutch area. How do you change the leaking seal?
    • By colin james
      View File 2018/2019 Polaris Sportsman XP 850/1000 Service Manual
      This is the factory service manual for the 2018/2019 Polaris Sportsman XP 850/1000
      Submitter colin james Submitted 08/01/2019 Category Polaris ATV  
    • By Jeremy Morris
      If you're getting that pesky leaky seal on the pinion of your front differential and the pinion has allot of play, polaris won't sell the bushing needed to repair it properly without having to shell out big bucks for the complete ring and pinion kit. 
      I have a kit with an upgraded bushing, Japanese made bearing and USmade seal
      50 shipped in the US and 55 to Canada

    • By Chase Cook
      I have a Polaris sportsman 500 and I just replace the piston in rings and head gaskets on it and I made sure the timing was exactly right it's getting gas and fire but it still won't start. It sounds like it has low compression but at the same time it sucks in air pretty good from the intake. Also the valves are adjusted to spec. It did start the first time I installed the Piston and Rings but it only stayed running for 5 seconds with starting fluid and then it shut off and then I tried to turn on the next day and it didn't do nothing and I've been going at it for three weekends now and it still ain't doing nothing. I wonder if i set the timing off a little or a lot if it would start up, because I inline the crankshaft sprocket with the crankcase timing line like it said in a manual and the two points on top of the cam sprocket to top dead center of the piston. I even took the spark plug out and stuck a camera light in there to make sure it was top dead center and it still won't do anything. AlsoI drain the carburetor some and shut d fuel petcock off to see if it was getting too much gas and that still isn't the problem. And where I live all the darn mechanics that work on Polaris ATVs are booked for two weeks which sucks and I need hope immediately or I'm just going to set the ATV on fire because I'm getting very frustrated with this crappy brand. Every other name brand ATV I worked on I got it running right and I replace the piston, rings and everything etc, and they started up fine. But this is starting to get very frustrated and I don't know who to talk to who had this problem before, who "don't have to come look at it". Cuz when they say that that means you're not going to come look at it until 2-4 Weeks later because there booked, which I don't have time for. Living in northern part of Florida sucks.
  • Similar Tagged Content

    • By Michael Aiken
      Where can I find a wiring diagram for my 2005 450 Kodiak. Thanks.
    • By Mo Salem
      So my front hub broke, I’d like to put aftermarket on. Hard to find new oe ones. Please help. I’m new to all of this, I have some car knowledge and try to apply it
    • By oxidized_black
      tag : zukifreak
       
       
       
    • By LMI
      Was using the quad the other day to shuttle wood from my pickup to my wood pile.  When the job was done I turned off the Quad and heard a bit of a racket from the front end.  When I got down underneath the sound seemed to be coming from the fan housing.  fan was moving in spurts and not quickly... much like a computer case fan that's had it's day.  What I know.
      Temp sensor is ok, as the fan tries to activate fan is getting some voltage as it is attempting to spin.  When I first bought it used I tested the fan direct to battery and it was fine. The fan was working ok even not direct wired as I went on a couple of rides and when stopped and idling the fan did run Seems to be free spinning with my finger read up in the manual and they require me to drop the rad.  now I'm not opposed to that as the rad has some damaged areas I want to try and straighten out.  But if I can get the fan working without, I can leave the rad as it is until next year.
      Fan assembly is about 300 bills, any work arounds or alternatives?  I even thought large computer case brushless fan.  smaller ones are about $7 larger ones better quality probably far below the 300.  They run standard 12v DC.
      Anything I should be doing before dropping the rad... other than check for obstructions even though it seems to spin, and trying to hardwire it to the battery again for a test to see if it acts the same?
    • Guest Fox300exchic
      By Guest Fox300exchic
      The Hop-Up: You may be saying to yourself, “that’s a chick bike,” and you’re right. But honestly, it’s so much more than that. It’s one badass bike. http://www.quadmagazine.com/quad/features/article/0,24942,1587044,00.html
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...