Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
Ajmboy

Suspension Problems?

Recommended Posts

Anyone encounter Polaris suspension problems specifically in the utility lines? Struts falling apart after some good hits...

Share this post


Link to post
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By Anthony Marceau
      Hi everyone! I have a 1986 yamaha moto4 200 that's been sitting for a while! Cleaned the carb, replaced engine oil, put fresh gas in it. Got it running and went for a ride! It was running great just a little backfire once in a while! I barely made it home on the way back and now the bike won't run at all since then! It will start if I give a little bit of throttle but dies instantly as soon as I let go off the throttle! And even if I try to rev it up it'll sound like its not getting enough gas.. it revs up a couple hundred rpm's and backfires through the carb.. it almost sounds as if I was trying to take off from zero in 5th gear! Nothing is seized though! I dissasembled the head and the piston and cylinder are fine! Rebuilt the carb, replaced the ignition source coil.. I don't know what to do anymore.. compression test shows 90 psi Specs are 128 psi but i'm not sure if I trust my compression tester.. any ideas? Thanks!!
    • By prityboy69
      Ok I recently put a 220kdx motor in a 150 falcon. The suspension can't keep up with the motor so I need arms, shocks, and four lug spindles & hubs. Does anyone know of a aftermarket suspension for this quad or even a set of arms that will work off another manufacturers quad such as Honda, Kawasaki, Yamaha, or Suzuki? Please anybody who has any information would be a huge amount of help. Thanks in advance!
    • By Bearman
      Long story short. I bought this off my neighbor and only has 3 gears. The part that holds the shifter rod on broke, this is on the inside where the clutch is. The rod moved out of its spot and when they welded it back together only has 3 gears. I have a new case for it just need to know how to get the shifter in the right spot before I put it back together. I am missing the indicator that shows me where neutral is. A link to a good Manuel would be great. Thanks
    • By waynep
      I have a 1996 kawasaki bayou 300 that i cant seem to get running for more then about 10 seconds i think i need it to spin a little faster. i had it giving it to me and havent ever worked on a four wheeler yet. i have already cleaned the carb and did all the maintainance things i could think of. and am hoping for a good starting point Thanks Guys!!
    • By chuey12
      I have a 2010 Z400 and it will start up an idle fine but when you go to give it gas it just stales out and wont run at high temp. Any ideas?
  • Recently Browsing   0 members

    No registered users viewing this page.


×