Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

ATVNetwork

HMF Competition Series Exhaust and Fuel Optimizer Review

Recommended Posts

When it comes to adding more power to your ATV, the first thing that usually comes to mind is bolting on a slip-on exhaust. However, that usually means you are also bolting on a lot more noise. HMF do...

More...

Share this post


Link to post
Share on other sites


I'd really.like to get a new system for the Z400. Right now I just have a White Bros. E Series slip on and stage 1 jet kit and a K&N. If I was to do a full HMF exhaust system would I have to re-jet?

Share this post


Link to post
Share on other sites

The HMF Is super loud! I liked the white bro’s better!


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Sturgeon
      Hello everyone, did a search and not successful. Purchased new 2017 Sportsman 570 sp and my power steering is not working. Seems to have a mind of it's own. Works then it doesn't. Dealer says there's not a fix. Thought it was just me and it being a brand new machine with 4 hours on it. Dealership said it's this model only ? Not sure what a person in this spot is suppose to do and wondering are your thoughts mite be. Thanks 
    • By Arizona
      Went shopping on Saturday, picked up another Kawasaki Bayou 220 and a Yamaha Timber Wolf 250
      I really should sell some of these but they are a lot of fun to find, fix and ride
      Of course neither of them run but that's part of the fun!  Az



    • By My kiwi shed
      Hi there everyone. Just seeing if there is advice on a problem I have before I start digging too deep. 
      I recently bought this creally nice 2004 King quad ltf300 with only 2400km..
      Everything things works great except when engaged into 4wd or diff lock it has a clicking noise ( sounds like broken teeth etc) are the front diffs known to blow?  Or the transfer from engine?
      I am yet to test on some loose ground to see if I'm getting drive at front .
      I will be driving in to find problem in next few weeks but thought I'd see if anyone might know what it is first. Cheers


    • By MarkinAR
      On a 93 Kodiak, and I am sure BigBear behind and below the clutch pack sits a claw of a piece. It has a stack of washer bearing washer, claw, 3 bearing plate, then stabilizer fork that sits on a shaft. What does that bad boy do?
    • By Chase Cook
      I have a 2001 yamaha yfm350x and it has a brand new top end, new carburetor (stopped the leaking problem and is now getting gas to it), new CDI box, new stator, handlebar switches work, off-and-on switch works, new starter solenoid (works), new neutral relay (works), ordered a new Rectifier on its way, good strong blue spark. Has compression, valves are right. Timings is right and is TDC. When I try to start it it just makes a loud popping noise like its backfiring but it's not because its not running when I push the throttle all the way and when i barly push the throttle it try to start but won't, so I'm trying to figure out what could be the problem not starting now, Getting very fustrated with this thing and put some work and money into it and it's not still not working. This is the only atv I ever had that I can not figure out the problem to get running. Need help please..
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...