Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

jblaze

2001 Suzuki LTF250 Quadrunner - Replacement Plastics

Recommended Posts

I recently bought a LTF250 Quad runner from this old timer that let it sit. I cleaned the carb, changed the plug, drained the gas, and changed the filters. It now runs great! Problem is the front fenders are broken and the battery cover is missing. I figured out from pic comparison that it is a 2001. I cant find used replacements for the life in me and don't want to spend 500+ ordering a new one. Are there any other models that will fit such as the 2002 Ozark or any other year Quad runner that are interchangeable? any help would be much appreciated as my hairline is starting to recede!!!!

Share this post


Link to post
Share on other sites


Thanks for the Post!. I checked out the link, but it doesn't reference anything to 2001...unless I'm not seeing it....which is a possibility

Share this post


Link to post
Share on other sites

I'm right???? Don't tell it to my wife....she wouldn't believe ya! ha ha. I found the front fender for a 99 on Craigslist, but still not sure if it will fit and hesitant in buying before i figure it out. Any ideas?

Share this post


Link to post
Share on other sites


Well after a little more research I found that Suzuki revamped their frame after their 99-01 models so the initial idea of using the 02 Ozark fenders was a pipe dream. Luckily, I found someone on CL selling same year non running Quad runner for $450. Apparently it is not running due to electrical issues. So I drove the 7 hours round trip and bought it to use for all types of parts. figure I can strip what I need and ebay the rest. Since the fenders alone without mud flaps were running between $290-$400 I found it to be a good deal for the entire quad. It has all the plastics, but unfortunately they are cracked. No chunks missing. Looks like I am going to have to consult with a body shop and try to figure out how to fix broken fenders! Any advise? Do I use bondo, epoxy,......a wish upon a shooting star...I have no clue! Hopefully someone has a direction for me. lol

Edited by jblaze

Share this post


Link to post
Share on other sites

Hi there, say you wouldn't have a working engine off that 2001 ltf250 that you bought for parts laying around that you would part with ,just wondering thanks Larry

Edited by Larry1968

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By jimsvtx
      I'm working on my brothers' 2002 Suzuki Vinson 500 . It sat for a few years before I got into it. I'm concentrating on the carb - I replaced orings, needle, etc. and soaked jets, bowl and anything that I could get off the carb that the solution wouldn't eat. I also removed the tank and flushed it with hot water - it's clean. The gas cap innards rusted away and the tank had a lot of rust and water in it before I cleaned it. I replaced the gas cap and installed a new fuel valve because the screens were broken in the old one. The bike will run but spits and sputters and backfires. If you "open it up" it falls on its face and stalls - but starts right up. Here is a link to an exploded view of the carb: Ohio Honda Yamaha Motorcycle ATV Dealer - J & J Motors - Kawasaki Suzuki Scooter Utility vehicle, parts, accessories, apparel
      Can anyone point me in the direction of the problem? It may still be a "clean carb parts issue" . My problem is that the parts list doesn't identify the parts to a degree that I understand. If you said" look at the pilot jet", I'm not sure which jet that would be....See what I mean? It'll run very good if I remove the air filter and cover the opening with my hand and part my fingers a little for the air to get in. Any help is greatly appreciated.
      Thanks in advance, Jim
    • By JacobSlabach
      Hey I have a 97 bayou 300 2x4 (klf300b) that i bought for 1000 last June and sunk another 1000 into it already.  When i went to look at it, the seller had warmed it up before hand (he was riding it when I got there).  it ran good so i bought it and took it home that evening... next morning it wouldn't hardly start.  I discovered the carb was clogged, there was chunks of rust in the fuel valve, the choke lever was missing and other things.  I have since cleaned the carb and replaced the fuel valve and gas lines and cleaned out the gas tank and cap.  
      Enough background on it, the problem is this:  It floods if i push it past half throttle in 4th and 5th gear even going downhill and shifting correctly.  It also has to idle and warm up when you first start it which is really annoying now that its cold...  It also smokes blue smoke for about 15 seconds when started cold-  does not smoke at all once warm but the exhaust still smells like burnt metal.  A friend told me that it didn't have enough compression.  I also found out that the valves are a common cause for low compression on Kawasakis..  I have never adjusted valves before-  the most I've ever got into a engine was a head gasket on a riding mower so I'm new to this.  My goal is to get this bike running and starting cold like a top-  should i tear down and rebuild the top end?  What should i try first?  I tore the carb apart and rebuilt it and fiddled with the air screw and nothing changed.  I also ordered a compression test kit that should be coming in soon.

      Ive also considered just selling it for like $500 and taking the hit-  Id rather not sink too much more into this machine..  lol
    • By JacobSlabach
      got 7 atvs off CL recently for a good price.  one of which is a yamaha warrior.  anyone know where the vin is printed on this bike?  Haha good place to start as I do not know year or size yet.  The former owner says needs exhaust ans and clutch work.  he said it ran fine until the clutch cable broke and then I couldn't get the new cable adjusted right and it would grind gears.  things I see:  clutch cable locked up again, no brakes, carb leaking (green with algae around the bowl and has gelled gas stalagtights on it), aftermarket exhaust melted the airbox so I need something different and a new air box.  I would like the use the current exhaust if I can but I have a feeling its a redneck fix as it looks like there is an ace bandage holding it to the exhaust pipe (its an aftermarket slip-on exhaust), so I'm not sure about that- lets get the bike running first.  also, battery (looks brand new, what a shame) is dead, 0 volts.  Otherwise, bike looks to have not been wrecked, and plastics are ok (it sat outside under a 'tarp' for 3+ years since it was run last).  any tips and advise on where to start first would be awesome as this is my first clutched bike (manual).
      the clutch is my main concern- I've never rode a clutched bike so I dont even know what its supposed to feel like.  lol I'm spoiled on my automatic polaris 
    • By JacobSlabach
      Got a 04 Sportsman 500 that wasnt running- owner said it needed a stater and a new battery.  It ran rough (been sitting out in the weather for a while).  A friend and I started by adding a new battery and it would start barely with the choke and his hand over the air-filter.  I decided to install the new battery in the holder on the side.  we had it on the rack because the old on was still in the bike.  I tried to be nifty by turning the battery to put the terminals in an easier spot to get to, but forgot to reverse the cables too.  In a sentence, I reversed the positive and negative on the battery like a dummy.  When we discovered my mistake and corrected it, we turned on the bike, but the display did not light up and the key did not turn on the starter.  jumping the solenoid worked the starter, so we thought the solenoid just burned up when I reversed the pos and neg...  new solenoid and no difference.  what have I burned up?  Also, the shifter does not seem to do anything in the trans.  it slides back and forth like its stripped in the trans.  any help would be appreciated!!
      I think the biggest issue right now is the electrical.
  • Similar Tagged Content

    • By Jers
      I need to know what I have and what tire really go on it, Mine has 24x11x10 on the back and 22x8x10 on the front and I need new tire but I don't think are the right size. Also I can't find the model number listed but it looks like a 250 quadrunner 2wd and I think it is a 1987 maybe, can anyone help me, also I it has a rich running sound and I put a carb diap in it and cleaned the carb. is there a jet needing replaced?
    • By Bits52
      Thank you for your help, just got quad for my daughter n needs a little work [email protected]
      It's actually a 2002 , just found serial number. Thanks for any help that you can !
    • By switch
      I have a really dumb question. My big bear came half apart and I am not sure how the timing chain guide is supposed to sit in there. I have the entire top end cleaned, bored, new piston, gaskets, etc. I do not see anywhere in any manual or thread where it shows how the chain guide is installed or held on place????? Also should it be the same height as the other side???
    • By biggreen2010
      ok it will start up an run but quits a lot till it gets warm, but has a bad miss an wont idle, I have a brand new Honda carb on it, good gas flow, new plug, but when I let the throttle go below a quarter, it backfires through carb an tail pipe:confused: so it has never had any electrical work or mechanical work done...it just started all the sudden, I'm think it may have ignition coil breaking down, or cdi box going bad...anyone had this trouble before? let me know what you did to fix it. thanks:skeptic:
    • By higdon87
      Need some help i have a 2001 400ex that smokes on start up and smokes even more when you give it throttle. I just noticed that it leaks oil at the header and motor connect. I just got it from a guy that said he rebuilt the top half and he told me that the valves needed to be adjusted. But what will make it leak? Thanks in advance
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...