Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

mb1968

2012 Kawasaki Brute Force 300 55W Driving Lamps

Recommended Posts

I installed 2 driving lights on the front of my 2012 300 Brute Force, My dad was walking by ,and added a comment " Better Watch it " you'll find yourself stranded. They are grounded , and the pwr wire goes thru a 2-pole simple switch.... on/off . I tapped into my cigerette lighter. Will that be a problem in the future it has a inline fuse. Does anyone think that adding a relay would be better than how i have installed it now ??? Comments would be appreciated !! Thanks All !!

Share this post


Link to post
Share on other sites


Should be fine as long as you don't use the cigarette lighter at the same time and overload the circuit. Make sure you have an inline fuse.

* Added year, make, and model to thread title.

Share this post


Link to post
Share on other sites

Yep got a inline fuse. Just wanted to keep the switching simple, thats why i used the two pole switch. My winch when they installed it tapped into the cig. lighter as well. But i gotcha dont use cig. lighter when running lights, dont use winch with lights on ,,, and so on. One more question i can use my regular headlights on the atv when running the driving lights , can't i ? I would think it would be ok, since the only thing pulling is driving lights !!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Jeni Lynn
      2012 Rancher ES-- only when driving in 4x4 when I get to about 15-18mph there is a loud clunk in the front end and a hard downward jerk. Its almost as if its trying to downshift itself. It doesn't do it in 2 wheel drive.  I have checked the angle shift sensor and applied dielectric grease to it, changed the front end differential fluid (the old still looked good and clean) checked and adjusted the clutch. Hopefully someone can give me some more ideas. 
    • By Vybrano Cz
      (I don't have manual and there isn't one on the internet)
      It's a 150cc ATV, automatic transmission, automatic starter, with zero electric devices.
      I have to mount at least some front/rear lights. But for how many watts should I aim in total on entire ATV? You know, for example there are 10/50/200 Watt lights. But it's impossible to order some, when I don't know if I should keep entire ATV under 100 Watts? Under 500 Watts? Under 1000 Watts?
    • By StolenATV
      On Wednesday, September 18, our ATV was stolen from in front of our house after the locks were cut. This was around 2-3:15 AM.
      We realize the likelihood of ever finding the four-wheeler again is slim to none, but we had to try and put the word out there. We have put countless hours in to restoring this Banshee. It was more than just a passion project, it also was our investment for a down payment for our future house. We are devastated and beyond heart-broken. If you see any suspicious postings on Facebook Marketplace, Letgo, Craigslist, etc., or have any other information, please contact us or the Prince William County PD.
      *Update* We received a tip last night that it was possibly posted on Facebook Marketplace around 8AM yesterday morning with only pictures of the front and of the back of the ATV. The description only said: PM for more details. This came up in someone’s FB Marketplace feed that has it set for a 50 mile radius from Hartwood, VA. She also has her feed set to automatically translate everything into Spanish, so It could also possibly be posted in Spanish.
      WHAT WAS STOLEN:
      2004 Yamaha Banshee YFZ 350
      White plastics with bright green and pink graphics/stickers
      STOLEN FROM:
      Prince William County, Triangle, Virginia
      $500 REWARD FOR INFORMATION LEADING TO RECOVERY. BONUS FOR CONVICTION.
      The post Stolen From Our Front Porch – 2004 Yamaha Banshee YFZ 350 appeared first on STOLEN 911.
      View the full article
    • By Mo Salem
      So my front hub broke, I’d like to put aftermarket on. Hard to find new oe ones. Please help. I’m new to all of this, I have some car knowledge and try to apply it
    • By Arizona
      On one of the atv I recently purchased the neutral switch is bad, Any one ever replaced one.
      looking for some pics. I assume I need to remove the drive shaft to pull the cover foward
      to clear the gear shift shaft. Any easy ways to do this. So far have motor moved forward 
      all bolts out except nuts on drive shaft which are loose Thanks Az
  • Similar Tagged Content

    • By seth
      Well the instrument lights on the 95 425 magnum are all out so i decided to replace them with led's Turned out looking really nice. Don't have an after shot but here is the during shots..
      Little Time, super bright Led's red blue green orange, and some resistors it turned out pretty cool looking...
      and will never burn out!!!!





    • By ejtaylor25
      OK long story short....bike was running great no problems and i was back in the woods one day and it stalled .It wouldnt restart ,kept wanting to but it wouldnt.I towed it home.It sat in garage for a week ,i would try starting it every couple days ,it wouldnt.Then one day it fires right up.I kept starting it once a week with no problems.Then after a month same thing just wouldnt start.I but a battery tender on it for a day, then it fired right up,problem fixed i thought.So i turned it off and tried again and it just turns......IM going crazy over this thing,the battery is good.....
      Any help would be super
    • By DJLime
      I don't know if there's anyother thread of this. But the Hippie's are trying to banned all type of offroading from ATV's to Trucks.
      So here's a quote I got to pass on to my other ATV site's
      I signed it I'm #993.
      .
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...