Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

2008 Arctic Cat (Bogue Chitto )


Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • OEM Parts at Aftermarket Prices
  • Similar Topics

    • By SodRiPPER
      I have a 2006 artic cat 500. It runs fine, but once you put it in gear it wont budge, cant push it, wheels are locked. If you try to throttle up, the motor bogs down, almost like its gonna choke out.
      Put it in neutral and it will roll all day.
      Is this a belt issue, or am I looking at major repairs.
    • By YamahaGrizzly
      So It took me a little longer than expected to even look at my Grizzly, Hopefully the N2deep Rad kit will be installed Saturday! Check out the little shed vlog! Make sure to Like and Subscribe to the youtube channel!
       
    • By Tundra550
      Just picked this bike up for my 9 year old son.  Wasn't run for 10  plus years.  Not a crack in the plastics.  Paid 1200 Canadian for it.  Needed rear bearings and seals and a drive shaft boot.  I also put new tires on the back.  Where these good bikes? Thanks 



    • By Chad Dickerson
      Hi all i am working on a rincon 680 that if i hold the starter button down it will start right up and run just fine, untill i let go of start button? I replaced solenoid thinking it wasnt holding the constant after the momentary voltage? I cant find a relay anywhere on it so im thinkin if there is a kind of relay it must be in the ecm? I cant afford to buy a serbice manual right now. Any ideas out there or anyone have a service manual for it? It runs fine revs up and everything as long as button is held. Any help greatly appreciated 
    • By quadcrazy
      If you are a new member, why not introduce yourself? This community thrives and grows with you and all our current members! We all want this community to grow and encourage new member registrations. That being said please help out QuadCRAZY by inviting other atv'ers to the community.
      QUADCRAZY NEEDS YOU!
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...