Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

dawghouse

2003 Kawasaki Mojave KSF 250 - Needing HELP!

Recommended Posts

My son has an 03 kawasaki mojave ksf 250 and the thing idles fine and starts right up but when you start off in first gear the thing brakes up and spits and sputters till your moving I noticed that as soon as you are off idle it is fine,I cleaned the carb and gas tank but still no better any IDEAS?

Share this post


Link to post
Share on other sites




Did the plug take care of it, then?

I tried the plug but no luck but I had a friend take a look at the carburator and he said there were a lot of hands in the carb before I got it and that the jetting was wrong and parts were missing he was surprized it ran at all so I am having someone who knows what they are doing to work on the carb cause I have no clue when it comes to carbs and jetting

Thank you for your help

Share this post


Link to post
Share on other sites

Hi all, I'm going to change the oil in the engine just did not know how many gallons pour. Do you know how much you can pour liters of oil into the Kawasaki KSF 250?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Forum Topics

    • By JacobSlabach
      Hey I have a 97 bayou 300 2x4 (klf300b) that i bought for 1000 last June and sunk another 1000 into it already.  When i went to look at it, the seller had warmed it up before hand (he was riding it when I got there).  it ran good so i bought it and took it home that evening... next morning it wouldn't hardly start.  I discovered the carb was clogged, there was chunks of rust in the fuel valve, the choke lever was missing and other things.  I have since cleaned the carb and replaced the fuel valve and gas lines and cleaned out the gas tank and cap.  
      Enough background on it, the problem is this:  It floods if i push it past half throttle in 4th and 5th gear even going downhill and shifting correctly.  It also has to idle and warm up when you first start it which is really annoying now that its cold...  It also smokes blue smoke for about 15 seconds when started cold-  does not smoke at all once warm but the exhaust still smells like burnt metal.  A friend told me that it didn't have enough compression.  I also found out that the valves are a common cause for low compression on Kawasakis..  I have never adjusted valves before-  the most I've ever got into a engine was a head gasket on a riding mower so I'm new to this.  My goal is to get this bike running and starting cold like a top-  should i tear down and rebuild the top end?  What should i try first?  I tore the carb apart and rebuilt it and fiddled with the air screw and nothing changed.  I also ordered a compression test kit that should be coming in soon.

      Ive also considered just selling it for like $500 and taking the hit-  Id rather not sink too much more into this machine..  lol
    • By gutthooked
      What kinda of gear does everyone wear in the winter season to keep warm and safe? 
    • By pokerl0w
      this bike! did this guy sucker me or what.. ok, looks like this means something is bent that I do not see or one rod is longer vs the other?
      how long do you think this would last before it ripped into the tire? this is the right side, left side tire clears no problem

       
       
      I can not find them on www.kawasakipartshouse.com
       
    • By tundrawolf
      Hi, I have one of the very first Rincons. Recently after sitting for a while, a few months, it will start but not idle.
      I took the carb off and cleaned the jets, but they seemed clean. I have tried adjusting the throttle stop idle but it still stalls.
      I absolutely do not like CV carbs and I don't know much about them, but what else could this be? If not clogged jets there's so many hoses and tubes on this thing and wires and sensors I don't know where to begin.
    • By 220Bayou
      Hi everyone,  I'm about to get my first ATV, 02 bayou 220.
      Neighbor said I could have it if I fix it, Carburetor problems, and needs a new ignition switch. last ran 2 years ago, said he changed the oil in it twice a year and never ride it hard.
      Hope I got me a good ride.
  • Similar Tagged Content

    • By kemperboy01
      i have a 2003 yamaha big bear 400 i have a jumping idle and at low speeds it cuts off untill warm i have bought a kit for carb adjusted carb it still doesnt work so im either going with valves or electic issue im wondering if it is my stator what yall think??
    • By dIrTee_dEEdZ
      Hello i have recently purchased my kids a second hand Kazuma as a beginners bike, i would love to add a speedometer and a RPM tacho if possible for a little added safety so they dont flip it but i really have no idea where to start, sorry if sounds silly, .....how and where do i connect the speedo to(I mean electronics wise) and also how and where do i wire/connect the tacho to?
      Thanks in advance
      Allan
    • By Jeremyv
      I just bought a 97 big bear 350 2×4 for the family to ride.. it's smokes real bad on start up and ride, the guy I bought it from said it just needs rings.. should I go ahead and replace the piston, rings, and hone and bore it if it hasent already been done? And where can I find the parts for a good price??? Also should I let my kids ride it the way it is, will it trash it out if they do??? Any info and options is helpful and welcomed, so please c him in!!!!! Thanks in advance!!!
    • By rootbeerkid89
      hi i just got me a 89 yamaha breeze 125 and i was woundering how to take the battery out thanks
    • By tuddyt
      im new here and have a problem bought a 04 honda 400 at and i change the centrfugal clutch,drum and one way bearing now when the engine is cold it grinds,boggs down until the motor warms up then everything works fine. put 20/50 gn4 honda oil in it also appreciate any help thanks
  • Recently Browsing   0 members

    No registered users viewing this page.


×