Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

ndducks

1995 Suzuki King Quad - Broken Camshaft Help

Recommended Posts

I recently discovered I broke the valve cam shaft in my 1995 King Quad (model LTF4WDXS). The break point was right next to the timing sprocket. Could someone help me w/ a few questions?

First, the place where the cam shaft broke has scored the seat where the shaft turns on both the top and bottom of the valve cover. To the point where it looks and feels rough. Can I use a very fine grinder to hone out some of the rough areas or will it likely oversize the housing and the shaft will wobble? OR is it repairable?

Second, if it is repairable, how do I time it? Can someone suggest the procedure or a resource to learn that procedure?

Thank you in advance for your help.

Share this post


Link to post
Share on other sites


As for repairing it yes but requires it being done at a machine shop. They would build it up with weld and then machine it to factory spec. Check out the Kawasaki thread on here for your shop manual. That will bring up to speed as to how to time it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

    • Guest Fox300exchic
      By Guest Fox300exchic
      The Hop-Up: You may be saying to yourself, “that’s a chick bike,” and you’re right. But honestly, it’s so much more than that. It’s one badass bike. http://www.quadmagazine.com/quad/features/article/0,24942,1587044,00.html
    • By katasha2
      I took apart the carburator to clean out and I can't remember exactly where the springs that are inside the float are supposed to go I've tried to look up schematics but I think I am missing a spring maybe need helpt:confused::confused:
    • By skgw1
      Feul pump went out. Replaced. At times quad cuts out like its not getting gas. Saw article on new pump needs to be calibrated. Told how to go into a service mode. Does not tell how to calibrate after going into mode. Can anyone shed light on this procedure.
  • Similar Topics

    • By Wiley1
      Anybody know what the valve clearance is for intake and exhaust on a 2017 sportsman 570?  I did a search but it came up with nothing.
      Thanks
    • By Abbeypalm
      While cruising, my 2011 750 king quad suddenly shut down. As it happened, red lights on the display flashed. Any ideas? My head lights suddenly stopped working about a week ago, if that helps. I have no power at all. Thanks 
    • By Sha35297
      So, I got this 07' Polaris Outlaw 90 in the shop to rebuild top end and transmission. Replaced all bearings and gears in the transmission. Replaced cylinder and piston with brand new parts. Put the engine back on the frame and fired it up. Started great, but had a taping sound in the lower crank case. pulled the flywheel cover off and found the flywheel was wobbling and hitting the stator. I then replaced the stator and flywheel with brand new parts. Timing is all set on the timing marks now, but when I turn it over it kicks back when it fires and ends up stripping the starter idler gear. I've replaced the starter gear once already and now have to replace it again. Is it possible that the timing marks on the flywheel are off or maybe this flywheel is not for this exact model? Thinking of advancing the timing to try it, but don't want to keep going through idler gears.
    • By Brennon Heflin
      So I bought a 2000 quad runner 250. I'm having some issues an wondering what it could be I replaced the pet cock valve an the fuel filter an pump inside tank I also put a voltage regulator on it. The problem I'm having is that when u give it half or more throttle it bogs down an loses power what could it be the bike is almost like new an cant figure it out any help would be great
    • By smitht18
      Looking for the rectifier.  Most bikes have near magneto.  It appears the KQ has it in front.
      Can someone tell me exactly where it is? 
      Bike not charging and magneto checks out ok
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...