Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

ok i have taken the clutch cover off and got the water pump out the metal seal that is in the case were the impeller shafts goes how do you get that out i guess its part of the mecanical seal that is pressed in the case how do you get that out

Share this post


Link to post
Share on other sites


Usualy seals are been pop out by screw driver with intention of always putting a new one. Always be careful when time of prying with screw driver don't want to score or mark any metal surface .

Good luck

Alain

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By JacobSlabach
      got 7 atvs off CL recently for a good price.  one of which is a yamaha warrior.  anyone know where the vin is printed on this bike?  Haha good place to start as I do not know year or size yet.  The former owner says needs exhaust ans and clutch work.  he said it ran fine until the clutch cable broke and then I couldn't get the new cable adjusted right and it would grind gears.  things I see:  clutch cable locked up again, no brakes, carb leaking (green with algae around the bowl and has gelled gas stalagtights on it), aftermarket exhaust melted the airbox so I need something different and a new air box.  I would like the use the current exhaust if I can but I have a feeling its a redneck fix as it looks like there is an ace bandage holding it to the exhaust pipe (its an aftermarket slip-on exhaust), so I'm not sure about that- lets get the bike running first.  also, battery (looks brand new, what a shame) is dead, 0 volts.  Otherwise, bike looks to have not been wrecked, and plastics are ok (it sat outside under a 'tarp' for 3+ years since it was run last).  any tips and advise on where to start first would be awesome as this is my first clutched bike (manual).
      the clutch is my main concern- I've never rode a clutched bike so I dont even know what its supposed to feel like.  lol I'm spoiled on my automatic polaris 
    • By Adrian Ciotinga
      The title pretty much explains it all. When using the starter I can hear it spinning but not engaging the engine. The wheels also do not engage with the wheels when the clutch is out. The motor has compression if that helps.
      I am new to engine work and repair and I bought this quad with the idea of fixing it up (not knowing the full extent of the damage). The previous owner said it ran but sat for a year (I don’t believe that for a second after opening it up) and had bought a few new plugs and a starter motor, none of which fixed the issue.
      Any help would be greatly appreciated!
      I have attached a few pics of what I think could be wrong.




    • By Babu Romasko
      Hey guys, got a 2016 Canam BRP and i ordered a new mirror cover from the dealer and the part is not correct.
      Can someone help me locate a part number for this cover?
       
      Appreciate your help!

    • By Brad Lawson
      Hello all, I’m working on my sons 99 Yamaha Warrior 350. When I pulled the plastic cover off left side of engine, I can see oil leak at the seal. I pulled the bolt out and then the starter boss(I guess that’s what it’s called?) I can see that the boss doesn’t make contact with the seal. Is there a spacer of some type that slides on to the boss, to make contact with the seal? This seal is held in place with a plate with 3 screws in it. This boss slides into the bearing in the stator. I have been to parts websites and I don’t see what I’m needing. Maybe it’s just the wrong seal?
    • By Gary Patch
      Hi can anyone help  my 2008 linhai quadzilla 300 is clutch is not doing its job properly the drive is engaging at idle speed slightly    Can I adjust this and if so how thanks
  • Similar Tagged Content

    • By bradleyheathhays
      Life got the best of me this year and to make a long story short my '11 Grizz 700 has a half tank of gas (w/ no stabilizer) and hasn't been started for around 9 or 10 months. I have apologized to it and promised this will never happen again, but in the meantime I'm faced with what to do to remedy the problem. Ideally I suppose I should get the tank off and drain the gas, replacing with non-EtOH gas (which thankfully I just found in my area).
      Any advice on how to get this done (draining the tank) or how difficult it might be?
    • By gyminis
      HELP, i have a 2009 yamaha grizzly 700 yfm7fgpy special edition with a defective fuel pump and am wanting to know how to test it to know if it is defective or not
    • By OutlawGade
      [ame]
      [/ame]
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...