Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

trg804

New guy in Washington State (Southeast)

Recommended Posts

Hey everybody,

I am in Southeastern Washington State (Kennewick) and would like to find others in this area that are interested in ATV riding (quad) around here or places near here (SE Oregon, Idaho, etc.).

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Brittany Jones
      Yes I just got a 1998 polaris xplorer 400 4x4. Ran fine after hauling then died. Cleaned carb and put new fuel filter, hose, and new battery in. Starts 3 out of 10 times but will only run for a short time. Any suggestions?
    • By bryanta0502
      Hi, im looking to increase the power of my 1995 king quad 300. I was wondering what other people are doing to increase the power of their quads. Are there any big bore kits, would putting bigger jets in the carb do much? Just wondering what I could do.
       
       
      Sent from my iPhone using Tapatalk
    • By Shane Pillar
      Talk about what kind of atv you have and what you do with it.
    • By crochet homemade
      I have bought a 1996 suzuki king quad 300 and I have noticed that it smokes but I have put oil in it and plenty of gas had to fix shifter bc the nuts and bolts came out somewhere. I have had to replace the wire for the starter but now when I try to start it it wont idle at all and when it does run it smokes really bad like a whitish blue I guess, and it likes to stall a lot. So anybody can help me out please and thank you

      10000000_310855426253462_714534016610467840_n.mp4
    • By Alex91
      I have a 92 suzuki king quad that seems to be getting way to much fuel in my spark plug hole as I took out plug cranked it over and covered myself in fuel I cleaned carb and fuel filter and fuel pump all seems fine any other ideas
  • Similar Tagged Content

    • Guest DunePrincess
      By Guest DunePrincess
      Hi Y'all.. I'm new to the site. I added a few of our favorite riding spots. I'll keep adding more..
      Just wanted to introduce myself. I would love to meet more Washington riders- and more female riders!. So stop by and say Hi!

    • By outodoors
      Hey all, I am new here, new to quads well owning them anyway, I am a certified Chrysler mechanic and we just got 3 quads. a 99 Honda trx300 fourtrax 2wd, and 92 Yamaha YFM80 Badger, and a Suzuki lt50. So far it has been a great thing for me and my boys to do together. Looking forward to learning a ton of information.
    • By bilzhorse
      New guy from Stafford, Va. I'm about an hour south of Wash, DC and and hour north of Richmond, Va. My sons and I love to go wheeling. We have been going to Taskers Gap in Edinburg, Va. We have four ATVs: 1991 Honda Fourtrax 300, 1995 Honda Fourtrax 300, 1996 Yamaha Big Bear 350 4x4 and an Arctic Cat 500 4x4.
    • By br1ck5
      Hi all, Looks like this forum is a good way to connect with other atv riders and share knowledge. I own a 01 Foreman 450 and 08 Teryx 750. See you around guys!
    • By RexaFORD
      Brrrrrrr gonna get cold here tonite.....around -13 to -15*.
      Anyway just wanted to say hi. Just got myself a 2001 Suzuki Kind Quad 300 with a snow blade. Sounds like I'll be putting it to work in a couple of days.
      Anyway Hi again!!!!!
      Glad to meet ya all.
      Rex
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...