Quantcast
Jump to content

  • Do you own an ATV, UTV or SxS? Join our Community Forum!

    QUADCRAZY ATV Community and Forum are FREE to join! We keep our ATV, UTV, and SxS forums clean and user friendly. All first time posters in our forums will have to wait to have their content reviewed and approved. Once your first ten posts are approved, you will no longer need to go through a forum post approval process. To bypass the approval process with immediate access and a NO ADS experience in our ATV, SxS, and UTV forums, consider subsribing to a Premium Membership

another new guy


dakotasnake

Recommended Posts

this is my 1st atva kawisaki bayou 300 4x4. its alot of fun. im in the process of retireing from farming so i have plenty of time and plenty of places to ride. iv been useing the beast for checking fences and my trap line. i wasnt sure how it would do in the snow, thats why i call it the beast, havent been stuck yet. looking at the map it appears im the only one on here from s dak. i guess s dak. is one of the few states you can lisence and drive atv's on public roads. not sure if ill do that yet or not. theres nothing i have to work on yet on the beast but im sure ill eventually be looking for a manual to make adjustments etc.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By marlon smith
      1990 kawasaki bayou 300c idles fine but pops out exhaust and intake when trying to excel, will not take throttle past 1/4 , any one had this problem?
      have replaced carb twice, same thing, fresh built engine cylinder head, same as before, new spark plug, flywheel key is good, pulser test good, good spark
    • By p5200
      Can someone please tell me what size socket I need to remove the valve cover? Thanks! 🙂
    • By huntindog
      I am in the process of puting it back together after replacing the DPS gearbox.
      The manual I have states that it will need to be flashed by a dealer. Is this still true?
      Also , I have a mystery bolt That I cannot remember where it goes. M6x 70 or so.  Hex head with a flat washer.I will try to attach a pic.
      Pic is no go for now....Cox issue I will try again later
      TIA
    • By beast6228
      I've been trying to piece this Lakota 300 back together, slowly. It's been a rabbit hole however. I replace one thing, then it leads to replacing other things. Anyway, When I got this thing I noticed that the hose coming off the camshaft cover wasn't attached to anything, it was just hanging loose. (It's literally just a foot long hose attached to nothing) I figured since it was venting the head it would be ok and I am sure it is.
      However, last night I was looking at the service manual and noticed that it mentioned that this atv has a crankcase breather tube as well. Mine does not have one, so I looked at Partzilla and looked at the parts diagram and sure enough, it's definitely supposed to have one. The problem however is, the service manual does not show how it hooks up and the parts diagram only shows the exploded view of the assembly. I just find that kind of strange, nowhere in the manual does it show how it connects. Does it have it connector, attach to a nipple? It just doesn't say and it bothers me that there is a hole there without anything attached to it.  If anyone has a Bayou 300 or Lakota 300 with an intact breather vent system and could possibly take some clear photos of it or know how it connects I would be very grateful. I have searched high and low and cannot find any information on it.
       
      Thanks


    • By SCmasterTech
      I think I have a bad axle as only on wheel drives. I'll be taking it apart soon and was wondering if it usually goes bad at the hub or differential end?
  • Similar Tagged Forum Content

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...