Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

schreck562

2011 king quad 400asi ISSUE

Recommended Posts

I got a 2011 king quad 400 asi thats fuel injected (throttle body) when machine is cold it runs great, after riding it for a while it gets extremely sluggish when ur just kinda cruising with a little bit of throttle applied, goin about 8-10mph with just a little bit of throttle it feels and sounds like the engine is struggling or under an extreme load, if u give it more throttle it will pick up and take off and run great, it seams to me i got fuel/air problem but know nothing of how to work on fi atv, i changed and used all grades of gas, changed plugs ( which r black as coal) , if u take aircleaner out it will run better for a little bit then it seems to get worse, it will also backfire when freewheeling or coasting down a hill whether its 1mph or 10mph short of taking it to the garage and raping my wallet i dont know where to go or what i can do do solve the issue if anything, i dont wanna have to spend $300 on a fuel programmer for a machine that should run fine without one, oh forgot to mention the kg is completely stock and only has 660 miles and 140 hrs, can anyone help???

Edited by schreck562

Share this post


Link to post
Share on other sites


You need to get a read on your ECM first. Call auto or ATV part stores and ask if they have the ability to read. It requires a "dealer tool" which plugs into the ECM connector. You can jumper it but I wouldn`t advise this unless you are an experienced mechanic. I did a quick search to buy one but haven`t seen anything. Here is a basic description of the process.

Getting trouble codes from your ECU on king

Share this post


Link to post
Share on other sites

Thanks i will def try that when i get home from work, im definately comfortable doin this as ive done it on my car, thanks do much for the info as im frustrated as all hell with way its running on the low end, ill post what i find out

Share this post


Link to post
Share on other sites

Repair manual, no, just havent got around to getn one, just got quad end of feb, just have owners manual, ill check that site out thanks

Share this post


Link to post
Share on other sites


That link was for an older model and might be configured different. Get a manual to be sure you are on the right pins and have the correct procedure.

Share this post


Link to post
Share on other sites

I called dealer and they said with that model it has to b taken to dealer and hooked up to computer to read the codes and reset them, my machine is running rich especially at low rpm so was hoping there was a code, but dealer told me being its a throttle body there still may b air/fuel adjustment screw on outside of the tb, ilk check that out later i quess

Share this post


Link to post
Share on other sites

I doubt it, its a 2011 with 600 miles, im second owner, i got it with 480 miles but of coarse i dont know how long of a warrenty suzuki gives and the guy i bought it from said nothing about it, honestly i never thought to ask, i suppose i could call the dealer from which it was bought, what it the typical warrenty?

Share this post


Link to post
Share on other sites


No idea what Suzuki`s warranty is. Give the dealer the vin number. They should be able to find out. Worth asking the question regardless.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By JacobSlabach
      Hey I have a 97 bayou 300 2x4 (klf300b) that i bought for 1000 last June and sunk another 1000 into it already.  When i went to look at it, the seller had warmed it up before hand (he was riding it when I got there).  it ran good so i bought it and took it home that evening... next morning it wouldn't hardly start.  I discovered the carb was clogged, there was chunks of rust in the fuel valve, the choke lever was missing and other things.  I have since cleaned the carb and replaced the fuel valve and gas lines and cleaned out the gas tank and cap.  
      Enough background on it, the problem is this:  It floods if i push it past half throttle in 4th and 5th gear even going downhill and shifting correctly.  It also has to idle and warm up when you first start it which is really annoying now that its cold...  It also smokes blue smoke for about 15 seconds when started cold-  does not smoke at all once warm but the exhaust still smells like burnt metal.  A friend told me that it didn't have enough compression.  I also found out that the valves are a common cause for low compression on Kawasakis..  I have never adjusted valves before-  the most I've ever got into a engine was a head gasket on a riding mower so I'm new to this.  My goal is to get this bike running and starting cold like a top-  should i tear down and rebuild the top end?  What should i try first?  I tore the carb apart and rebuilt it and fiddled with the air screw and nothing changed.  I also ordered a compression test kit that should be coming in soon.

      Ive also considered just selling it for like $500 and taking the hit-  Id rather not sink too much more into this machine..  lol
    • By JacobSlabach
      I have a gentleman that asked me to service his bayou for him.  I have always wondered what oil should be used in atv engines?  Pros?  Cons?  What weight should be used in what type of weather?  Is there one kind that I could bulk buy and safely used in any quad I worked on or owned?  What about performance?  Engine Life?  This has always been a 🤔🤔🤔 area for me with quads as far as why you would use one type of oil over another....
      Thanks!
    • By JacobSlabach
      i know this isnt an atv but same type of thing.  I have a riding mower im fixing and selling for my aunt and it has a dead battery.  i jumped it off my atv and when i turn the key nothing at all happens.  i tried jumping the relay still nothing.  this is with the seat down.  you wouldnt think this mower would have issues as its a top-of-the-line brand and almost brand new (aunt found it for a good price, still got tits on tires, just sat for a couple months in a mechanic shop
    • By Dwight Williams
      Ok, so I bought this scream of a deal the other day - a 94 King Quad 300 for $40.00.  It's been sitting outside with no carburetor on it for about a year.  Its rusty, missing some parts, wiring is all cut up and spliced etc.  No seat, no racks but the plastic is all there minus the headlight housing.  Anyway, who can pass up a $40.00 quad right?  I get it home and looked at the sight glass for oil level, it's about 1/2 oil and 1/2 water.  I drain it, refill it and turn the motor by hand (recoil starter is missing) and it turns over just fine.  I worked on the wiring for about an hour and got it to turn over with the electric starter and got enough of it sorted out to get a spark.  Did a quick compression test, 70 lbs.  Wet test bumped it up to 90.  Ok, so rings and cylinder washed out with water for a year, not too surprised.  I thought 'what the hell' and sprayed some starting fluid in it and it ran for about 2 seconds - enough to show  it's got life.  Since then the compression has gotten worse, I can't get enough pressure to activate the carb diaphragm, therefore no fuel pump either.  The compression is now around 60.
        Anyway, my question is....is it worth it to try to get this thing going?  I tore the top end down today and the cam and one of the rockers is pretty worn.  I figured a top end job would be about $100 or so, depending on the condition of the cylinder but I'll probably have to put a cam and rockers in it as well.  Doing some research on ebay I figure I'll have to spend about $500-$700 to make the whole machine right again.  Much less just to make it run and use as-is but I won't really like it until it's right.  I don't mind doing the work, I actually enjoy it but I'm concerned about what all that water did to the rest of the internals, I can't really test it all out until I can make it run.
      I know it's a basket case but I'm not into it much at all, even if I do the top end and find something else wrong I'm still not out much.  I'm leaning toward ordering the top end parts and going from there unless you can convince me otherwise - any way to check the rest of the internals without tearing it down?  I plan on flushing the oil cooler before I do another oil change, I've drained it twice now and it gets milky almost immediately just turning the starter - I suspect the oil cooler is polluted badly.
       
      I'll get some pictures today if anyone want to see them.
       
      thanks!
  • Similar Tagged Content

    • Guest Fox300exchic
      By Guest Fox300exchic
      The Hop-Up: You may be saying to yourself, “that’s a chick bike,” and you’re right. But honestly, it’s so much more than that. It’s one badass bike. http://www.quadmagazine.com/quad/features/article/0,24942,1587044,00.html
    • By crazynordlander
      Hi All,
      I live in Minnesota and bought a 2016 CFORCE 500 HO. I am in hope to see if there is anyone in the US that is experiencing this sudden drop off in RPM below 4000 RPM. I have uploaded some videos of my issue on YouTube. I will list three of the four I posted. The fourth can be found on my channel but it is a comparison between my Polaris 570 and my CFORCE 500.
      I quit on my first dealer because we just did not mix well together. I brought it to another CFMOTO dealer that just became a CFMOTO dealer in January 2016. They are in a large ranch and agriculture area in a neighboring state that is pretty close to where I live. They have close to every brand available. They are a much larger dealer than the first one I bought the unit from.
      I brought the unit three weeks ago to them and they have worked on it a good solid week and have given up on it. I have read reports from owners in Canada that the dealers there were aware of the issue and have had success in fixing the herky jerky drivability issue.
      I am picking it up tomorrow and bringing it back home. It has been to the trails of the Black Hills this year and was new in late April. 300 miles on it. It has never changed. Very hard to ride on the trails or when I herd livestock.
      Here are the links to my videos.



      I can't accept that this is normal operation. Does anyone from CFMOTO China scan these posts?
      I need help that CFMOTO USA has not provided.
      Thanks
      Kevin
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...