Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    Join QUADCRAZY ATV Forum today for FREE! We keep these forums clean and user friendly. All first posters will have to wait to have their content reviewed and approved. Once your first post is approved, you will no longer need to got through an approval process. To gain immediate approval and a NO ADS experience, consider subsribing to our Premium Membership.

03 Predator 500 bucks


Fox500
 Share

Recommended Posts

I have a 2003 Polaris predator. Been sitting for about 6-7 months. Put brand new gas in it, new plug, cleaned the carb. Starts up no problem. Idles well. As soon as I put it in first and release the clutch to ride it, it rides but kind of bucks a little. Like its not getting fuel. As I give it gas it like sputters and breaks up. If I stop put it in neutral it idles perfect. Any suggestions?? Thanks

Link to comment
Share on other sites

I just cleaned it quickly. Seemed to help a lot. I will probably end up taking it apart this weekend. Someone else had told me the clutch plates could be sticking together from it sitting for a while? Which would be why it's bucking? Thanks Jon.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...