Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

I have a 1988 kawasaki mojave klf 110b it will start right up and runs fine but when you shift down you have to use your foot and pick it up and then push it down to get it to shift and it does the same thing to shift up it is like there should be a spring on it to pick it up or something please help

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By EoNe Frost Vortex
      Hello i was wondering if someone could help me out iv recently got a Kawasaki klf 220 it needed big end bearing changing so i rebuilt the engine and the bike has compression starts first time every time but after i have been riding for about 10 minutes oil starts to leak from the head just below the exhaust so i replaced the gasket still done it so i took it to a shop he done the same and it is still doing it any information would be great thank you
    • By daynick
      Only have about 60 hours. Sometimes and most often when I just accelerate I'm hearing a metallic clunking noise that seems to coming below the gas pedal or towards the lower front section of the UTV. It does not sound horrible but it really does not sound good. It only lasts for about 1 or 2 seconds. Could anyone please give me any ideas what might be happening? Thank you.
    • By Billy Aldrich
      2001 Honda foreman 450s manual shift. i can shift through the gears when the ATV is off, but when I turn it on, I can shift into first, but I cannot shift to second or even back to neutral. Same with reverse. I can get it into reverse but cannot shift out. If i turn it off it will shift back fine, any idea? I just bought this and fear I got screwed over. 
    • By Steven Urban
      First time using this forum.  Owned a Kawasaki dirt bike once, had no issues.  But I picked up this 4 wheeler at an auction.  They stated it ran, but only needed a battery.  Well I do not believe that was all true.

      Some pictures are attached.  Not sure why, but the whole air filter stuff was removed.  They had some small thing inserted as a make shift air filter.

      I purchased a battery to try this all out.  Waiting to return it and get the proper size, as it was too big for the battery box.  But here is my issue I had while the battery was connected.

      1 - The lights on the steering column did not come on.  Not sure if they work or not.

      2 - The starter solenoid seems to be bad.  I have a new one on order. 

      3 - In the pick, there is another rusted part.  Not sure what that part is or what it is used for.

      4 - What is the 12v rectifier?  square bodied part.

      So when I hooked the battery up.  Pushing the start button did nothing.  Pulling the cord to try and pull start, it turned, but would never fire.  I have put in a new spark plug as well, it looked worn out.  With electric start, I crossed over the posts on the start solenoid, it turned over, but would never fire and start.

      I have read a few other threads and it stated something about needed the neutral light on.  SOmething about a kill switch.

      Any help would be appreciated.



  • Similar Tagged Content

    • By Guythis448
      Looking for help on wiring up stock wiring harness specifically for a '88 Honda TRX 300 
      If anyone could drop a link or send me a PM it would be much appreciated 
    • By wHarmon
      Our 1988 Yamaha Terra Pro is finally seeing the finish line of becoming our new bush hogging tractor! I've had the terra pro for almost 2 years... we had great intentions, but after removing the fenders, fuel tank, and the carb, we let it sit up. Shame on us! However, the terra pro is cranking today. We cleaned the carb, figured out what goes where and where did that screw go! She smokes like there's no tomorrow, but that's okay! The only issue right now is getting all these lines hooked back up to the carb right! There is 5 lines to hook up to this thing!! And in our moment of drinking and removing parts, we cant remember how they go back on. I've found several diagrams online, but none showing the overall schematics of all the lines! If anyone has a service manual, or any way of helping us figure out what goes where I would really appreciate it!! I can attach pictures later if it'll help!
    • By alexcross324
      Hi all, I try to find this manual in the threads but you have a lot of stock here
      Cannot find this particular manual.
      I found it for YFM200 but not sure if they are the same.
      Thanks if you could help me with that.
      Im new here so if I did something wrong, please tell me.
    • By alexcross324
      Hi all, my second post here
      I got an old Yamaha 88 moto 4 and I have a problem with my overflow hose from the carb.
      When I put the gas switch to ON a big amount of gas is leaking from the overflow...so I start using my quad with the gas switch to RESERVE wich is also leaking but less than in ON position.
      I dont ride a lot..but in a week I empty my gas tank.
      Strange.
      I never clean my carb because Im new to quad world and dont have the service manual...so I need you point of view.
      Thanks guys!
    • By pizzaman_288
      How hard is it to change the outer seals on the rear differential mine are leaking fluid and I have no idea on how to change them out any help would be great thanks
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...