Quantcast
Jump to content

RichUncleSkeleton

Members
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

10 Good

About RichUncleSkeleton

  • Rank
    Forum Beginner
  • Birthday 01/01/1971

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hello Did a lot of reading on this site, and have had some good luck. I shortened up the vacume line from the petcock to the carb, and discovered a small leak in the crankcase where it comes together. The gasket must be gone if it has one there. Used some chemical resistant cement to seal all along the seam, and snugged all the crankcase bolts. The leak was a drop every 2 days or so. And now it starts up everytime, but I have to keep giving it throttle for about 3 minutes, then it will idle on it's own. When I try to give it a little bit of choke to keep it idling, it just floods it, and it will quit. So now the bike starts fine, but I have to nurse the throttle for 3minutes to get it to idle on it's own, while applying the choke will kill it..... Any thoughts...? Thanks
  2. Hello Just signed up, as I've had a recurring problem, and need some help. To start the bike I have to put the choke on all the way and 4 squeezes on the gas, Then as I push the start, I slow squeeze the throttle about half way for it to catch....If I miss it, then it will take 5 mins of slowly finding the sweetspot on the choke in unison with some throttle squeezes. Then I have to to hold the throttle to keep the bike going, using the choke will stall it out. after about 3 mins of holding the throttle, I then can let it go, and it idles fine, and runs fine. If it sits for a few hours it's only slightly hard to start, but a few days of sitting, and it's a lot more work. Had the bike serviced they couldn't figure it out. They swapped peticock, plug, new gas, all new lines, new throttle, and cable. Said the carb was fine, and clean. New air filter, said fuel pump was fine, no leaks around carb boots, new battery, new rectifier. Ran some sea foam through it....Runs Great.....Just such a pain to start... Thanks

×
×
  • Create New...