Quantcast
Jump to content

mmsutton

Members
  • Content Count

    8
  • Joined

  • Last visited

Community Reputation

10 Good

About mmsutton

  • Rank
    Forum Beginner
  • Birthday 07/27/1951
  1. Found the oil filter and got everything changed and it's running great. Rode around some today getting used to the feel of it. Now it's time ot tackle that rear brake and see if I can get it working.
  2. Got the oil and filter today. Found the drain plug and fill plug in the parts diagram. Now can someone tell me where the oil filter is located?
  3. It's running like a new one now. The problem was the kill switch and the start button. Both were rusty. Finally got them cleaned, sanded and polished enough to make them work again. I had water in the carb and the butterfly valve was also rusty. Cleaned and rebuilt the carb and replaced the plug and it fired right off. Tomorrow I'll change the oil and filter and off I go. Woohoo!!!
  4. DirtDemon...do you have an online source for the service/repair manual? I have exhausted my web search capabilities and have not been able to find one. I've come close but not exactly there. Thanks, Mike
  5. Thanks DirtDemon...that's what I'm going to do. I haven't had any luck tracing the wires or finding a lose one anywhere. Mike
  6. Does anyone have an online source for a wiring diagram for this thing. I'm not having any luck without it. Thanks
  7. Thanks DirtDemon. I'm working my way through that process and haven't found the problem yet. I'll keep working on it.
  8. I just got an old Arctic Cat 300 4x4 that will not start. I replaced the battery and the lights work and the green neutral light is on but nothing happens when I hit the start button. I can short across the solenoid and get the motor to crank but not fire. I have checked the fuses and they all look good. I don't have a service manual and I don't know what to check next. Any help would be appreciated.

×
×
  • Create New...