Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Marlin18

2008/09 Polaris Sportsman 500 - Electrical Problem

Recommended Posts

I have a polaris sportsman 500 efi ho 2008-09 model and I cannot get power to anything. The volts are good on my battery. If I take the ground off of the frame and screw it back on I can get power to the pod but when I try to crank it I lose power to everything. It has a new solenoid and a new starter. Anyone have any ideas?? If it helps give any ideas I drive through mud and water so it does get put through a lot.

Share this post


Link to post
Share on other sites


bad connections ... take the battery connections and clean them with sandpaper, your ground, starter, and solenoid ... dielectric grease them too when finished ,,, hopefully this is all it is

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By colin james
      View File 1999 Polaris 500 Diesel Service Manual
      This is the factory servicefor the 1999 polaris 500 diesel 
      Download all the chapters for the complete manual or just download the section you need 
      Submitter colin james Submitted 09/05/2018 Category Polaris ATV  
    • By colin james
      This is the factory servicefor the 1999 polaris 500 diesel 
      Download all the chapters for the complete manual or just download the section you need 
    • By Ajmboy
      Hisun HS700/600/500 UTV Service Manual
    • By Dunnym
      I changed the starter and starter solenoid. Battery died so I bought a new battery.  Hooked up positive post first then I went to hook up negative wire and the atv tried to start. Key is not in the ignition and start switch is not being depressed. Anyone ever have this issue?  I was going to check solenoid with meter, but haven't had a chance yet. 
    • By jason baskins
      ive recently purchased 2 97 polaris 500"s . ive had both running but decided to build one good 4 whrrler out of boyh. well idecided to put a brand new carbuerator on it and it never hit a lick hasnt hit a lick since .  i checked the the throttle housing on the handle bars for that swith  and checked it every way i know how but still no spark any ideas ? thanks 
       
       
  • Recently Browsing   0 members

    No registered users viewing this page.


×