Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    Join QUADCRAZY ATV Forum today for FREE! We keep these forums clean and user friendly. All first posters will have to wait to have their content reviewed and approved. Once your first post is approved, you will no longer need to got through an approval process. To gain immediate approval and a NO ADS experience, consider subsribing to our Premium Membership.

STOLEN ATV: Silver 2002 Limited Edition Yamaha Grizzly


StolenATV
 Share

Recommended Posts

Dream Car Giveaway

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Topics

    • By TRUE69
      I just purchased the ATV and it run really rough with the breather filter on and lid on the breather box. Once I take the lid off and remove the filter it runs better but it backfires through the carb.
      What could I do to fix this.
      The carb is fairly new.
      And I put high grade non ethanol gas in it hoping it would help some.
    • By WIJBIRD
      Well, I’m completely stumped! I’ve been rebuilding a 1990 Big Bear 350 4X4 and finally got reverse to work. Here’s the strange thing, the shifting pattern is all wrong. Reverse is with the lever all the way forward and the forward position is down. What’s the issue? What linkage is backwards? Your help is greatly appreciated!
    • By e.p.
      Hi all;
      New to the site. I have a 2004 Yamaha Kodiak 450 YFM45FAR that I'm having issues with the gear indicator lights. I'm having intermittent park and neutral lights and when they are not lit the starter will not work. It will start by the pull cord . Anybody else have this issue. Any help is greatly appreciated.
      Thanks.
    • By ttu
      So just acquired this 2002 Suzuki Vinson LT-A500F and am in the beginning process of getting it to run.  I found two small screw size holes in the top of the tank, it would appear someone was not careful screwing something down to the plastic cover and accidently damaged the tank. My preface is to replace the tank but I am not finding any available, so can anyone give me any advise on this. If I do not find a suitable one at a reasonable price I will look at possible doing a epoxy type repair on this one. 
      Next is the fuel gauge, its missing and is creating another hole in the tank. I found this ONE which looks like it on ebay but the seller does not include any dimensions to verify.  So any advise on this will be greatly appreciated as well. 
      I did see the post on changing the fuel petcock with the Yamaha on/off valve which I have ordered already. 
       
    • Dream Car Giveaway
    • By Werewolf
      When I turn on key back light on the display works. The display shows shifter positions, temp and engine icon. But the main display is blank.
      It will not start fuel pump not working, but that info would come from controll Modular?
      Thanks for any ideas
  • Gallery Images

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...