Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Turtle Harris

Help with 110cc four wheeler

Recommended Posts

I have a 110cc four wheeler and I replaced the carb. Now when I hit gas it just wants to rev up . At full throttle the tires start to spin and go faster but not with any weight on it. It's a automatic. Drove and rode fine till carb work now it's got plenty of rpm but no pull .

 

Share this post


Link to post
Share on other sites


Does the throttle work when you press it and spring back? Did you properly install the slide back in to the top of the carb properly?   What adjustments did you use on the new carburetor? Don’t rely on a manufacturer setting. And what kind of choke is it ? On the carb lever or is it a cable type that is controlled on the handle bar ?  

Post a few pics if you can. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By orvilleortiz538
      I have a 110cc Chinese atv,the harness is in good shape,I recently bought a new stator,coil,CDI,spark plug,came as a kit from Ebay,and I still have no spark,I've watched a few videos from YouTube tried the same steps,but still no spark.... ???? Bad Flywheel??? I heard is very rare for them to go bad,(the magnets in them) I'm gonna check the harness very good again!!! I just can't get spark!!! Any suggestions Please!!!!
    • By MarkinAR
      What is the opinion on carb kits? What's one of the better brands of aftermarket? OEM is always preferred but not practical, chinese cheapie is never a good option. 
      Thoughts ?
    • By bradleyheathhays
      So this '02 Taurus with only 87k miles on her starts right up every time multiple times a day except for twice in the last 3 weeks. The first time was 3 weeks ago and the second was today. It happened the same both times. Turn the key and stop to let the pump prime, then when I turn to the start position the engine turns real slow and sort of in fits. Usually when a battery is low the engine turns slow but in rhythm. During my 2 starts the engine barely seemed to turn and the crankshaft rpm seemed to vary. On both starting events I let off the key and tried to start 2-3 times with rests in between. But then eventually on the 4th try it starts right up just as quickly as a normal start.

      I have No clue as to what might be causing this. Only thing I know to do is, next time it does this to put a voltage meter on the battery to see if it's weak. Actually though, because both events the engine ended up starting up like normal that would indicate something other than the batt. Electrically this car is a little odd though. The interior light never comes on when the doors are opened, for years, and then last week it comes on twice when one of the rear doors is opened.
    • By Reece Bowen
      x   just bought this expedition 425 and the Speedo needle does not work. The lights work for the shift indcator. So is this an electronic Speedo or cable? Is there a way to fix it or will I have to replace the unit? Thanks for any help you can provide.
    • By Kaj Colum
      Pushing the start button the engine turns and will forever without starting. But if I use the kick start it will start with one or two kicks everytime, any idea as to what is going on. New good battery and coil, I'm ready to try anything. It's a great bike, but this is getting anoying. Thank you.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...