Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Gary Patch

Honda TRX FM3 Rancher electrical issue

Recommended Posts

trx fm3 rancher switch ignition on turn anyting on on left handle bar switch lights or start button and ignition lights go out and sometimes don't come back on .not being too good with electrics anybody have any thoughts please😍

Share this post


Link to post
Share on other sites


Does it start? What year is it?

* Added ATV info into topic title.

Share this post


Link to post
Share on other sites
11 hours ago, Gary Patch said:

Did start  but temperamental on start button it's a 2003 ajmboy 

When you say temperamental, is it in terms of slow cranking or just wont catch and start? Wondering if the battery is good.

Share this post


Link to post
Share on other sites

sorted now ajmboy think lights or left kill /start switch was shorting out disscnnected lights as not needed joined the 2 wires on kill switch and put start switch independent ,well happy 😁thanks for your input though

Share this post


Link to post
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Forum Topics

    • 2005 Polaris Trail Blazer 250 won't start

      Hi guys, trying to get a quad running again. It was running fine but the electric start did not work. My uncle was using it and the pull start snapped. So I replaced the pull start and electric starter motor. Now it just cranks and cranks but will not start. I have spark, I have fuel to the carb, I know this is a 2 stroke with a separate oil tank, what else should i check?

      By TheJester517, in Polaris ATV Forum

      • 5 replies
      • 149 views
    • 1999 Suzuki King Quad lt-F300F Hard to start

      Hello Just signed up, as I've had a recurring problem, and need some help. To start the bike I have to put the choke on all the way and 4 squeezes on the gas, Then as I push the start, I slow squeeze the throttle about half way for it to catch....If I miss it, then it will take 5 mins of slowly finding the sweetspot on the choke in unison with some throttle squeezes. Then I have to to hold the throttle to keep the bike going, using the choke will stall it out. after about 3 mins of holding the throttle, I then can let it go, and it idles fine, and runs fine. If it sits for a few hours it's only slightly hard to start, but a few days of sitting, and it's a lot more work. Had the bike serviced they couldn't figure it out. They swapped peticock, plug, new gas, all new lines, new throttle, and cable. Said the carb was fine, and clean. New air filter, said fuel pump was fine, no leaks around carb boots, new battery, new rectifier. Ran some sea foam through it....Runs Great.....Just such a pain to start... Thanks

      By RichUncleSkeleton, in Suzuki ATV Forum

        
      • 4 replies
      • 1,839 views
    • 1994 Kawasaki Bayou 300 ignition problem.

      I am having what I think is ignition problems. My 1994 Bayou 300 seems to flood very easy when starting. At first I thought it was a carb problem but while testing the spart I noticed that there is no spark while the engine is turning over. When you let off of the ignition swith there is one spark. But only when you let off of the ignition switch. It has a new coil, plug wire, and plug. Any ideas? I dont know if it is the ignition box, or maybe the ignition switch. Any help would be appreciated

      By JamesD, in Kawasaki ATV Forum

        
      • 55 replies
      • 68,479 views
    • 2005 Honda Rancher bogs down and misses when accelerate

      I have a 2005 Honda Rancher 2-stroke. It's been sitting for a while. Yesterday I started it up and it idles well. When I tried to drive it, it bogs down and misses when I accelerate. Drained fuel, added new fuel and carb cleaner, and let it idle for a few minutes. It still bogged down, and I noticed a fuel leak under the carb. There's a tube from the bottom of the carb with something that looks like a filter. The gas was leaking from the end of the tube. Anyone have any ideas as to what the tube is, and what it actually does?  

      By frankc, in Honda ATV Forum

        
      • 6 replies
      • 158 views
    • Rancher 420 Rear end rebuild

      My 07 Rancher rear end started roaring on me the other day. I took the inspection plug out this afternoon and to my dismay it was dry full of rusty nasty crap. The pinion was loose and the axle seal was pissing out oil when I tried to top it up. I bought it used and usually check stuff over better but I missed that.  Muuuhhh Now I gotta take it apart and fix it. Not gonna be expensive, just time consuming. Hopefully the gears aren't too torn up. I cleaned out the nasty crap with some brake-clean and put in some fresh gear oil. Much quieter now just leaks out all the gear oil cause the seals are shot. I'll fill it up with some lucas and limp it along till I feel like fixing it.

      By Ahren Longo, in Honda ATV Forum

      • 4 replies
      • 123 views
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×