Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Ken E Scott

Hello from Kentucky

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By colin james
      View File 2017-2019 sportsman 450/570 with eps factory service manual
      This  is the factory service manual for the 2017-2019 factory service manual for the sportsman 450/570 with electronic power steering 
       
      Submitter colin james Submitted 09/06/2018 Category Polaris ATV  
    • By Larry Fox
      I have a 2017 1000s. Should I be worried that it will catch fire? 
    • By sprad22
      Hi I have a 2002 arctic cat 500 auto.starts and runs but will not go forward or reverse.the outer clutches/pulleys and belt spins but it will not move when put in gear.Any ideas as to what to to check for?clutckes,broken gear????
      thanks for any ideas..
    • By dbconn55
      Hi guys I have a 2003 Arctic 250 4X4 it starts idles and runs great for about 10 min. then it spits and sputters and dies but it starts right up like nothing happened idles good till you give gas and it does it again let off the gas and it's idling great again this goes on for about 15 to 20 min. and then it takes off runs good all day like nothing was wrong.
      I cleaned the carburetor it looked like a new one inside found a little gunk in one orifice, new air filter no crimped lines air line to tank good I did put a meter on the battery idling it said 16.5 V that's high I think would a voltage regulator cause this?
      Suzuki shop wanted to sale me a stator for $556.00 but said it could be something else also thought I'd see what you guys say about it
      Thanks
    • By stinky
      I have an Outlaw 110 that will struggle to turn the engine over. Jump starting doesn't help other than the battery will drain LONG before the bike eventually starts, so is required. If you keep messing with it long enough it will eventually magically begin to crank fine and sometimes finally start. Once we finally get the bike to start and warm it up thoroughly, it will turn over and start just fine the rest of the day like nothing ever happened... next day it won't turn over again.  Internet research has found lots of people saying they replaced starters, starter clutch, wiring, etc. but with only about 50/50 success rate for their particular problems... and I never found anybody describing a problem like mine, so I'm looking for advice/experience. Would rather not just start blindly throwing parts at it. Does anybody have any thoughts/ideas?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...