Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Debbie Jim Mills

2019 500 Suzuki king quad

Recommended Posts

Just picked up my new quad from dealership. Drove it onto truck felt for brush guard to touch front of bed. There isn't one.  Asked dealer. Says they don't come with one have to order it. They looked it up not available for at least 30 to 90 days. Winch mounting plate either. Been riding suzuki's since 1973. So i guess it will have to sit in garage till accessories are available. This is my fourth Suzuki ATV they all came with brush guards. Can't even imagine the damage you could get without it. 

Share this post


Link to post
Share on other sites

Congrats on the new King Quad! Post some picture, would love to see it. I'm a fan of king quads, had one a few years back. As far as parts, sometimes when they are the latest model year, parts go fast.

Share this post


Link to post
Share on other sites

Did you ever get your brush guard? I just bought a 2019 King Quad, with no brush guard , or winch, made me kind of hesitate buying it honestly but i had 2 Suzukis previous. Taking the cheap there and running up service fees are making this the last suzuki i ever get

Share this post


Link to post
Share on other sites
4 hours ago, Edcl54 said:

Did you ever get your brush guard? I just bought a 2019 King Quad, with no brush guard , or winch, made me kind of hesitate buying it honestly but i had 2 Suzukis previous. Taking the cheap there and running up service fees are making this the last suzuki i ever get

Congrats on your 2019, post some pics! I'm a fan of king quads 😋

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

  • Similar Topics

    • By Curtis01
      OK, sooo  I finally did the old skid plate and screen removal to clean out my oil sump during an oil change...  This bike only has a couple thousand miles on it.  Runs like a top still...  Very few issues over the years after buying it used.
      But boy I wasn't expecting to see this!  Piece of a circlip, stuck up in the screen, and a another shard of metal and maybe a piece of gasket material.  Nothing in the oil but that...  Pristine otherwise, and still runs like a top.  Always has.
      Soooo, is it a wrist pin clip?  That's the only thing I can think of like this that could end up in there.  But definitely wanted to throw it out to guys that have seen the innerds of these more than I have.
      The valves on this thing are still within the factory spec even.  Been a really good lil workhorse...
      Any other ideas?

    • By Countryboy57
      Hello I’m new here and I need help finding out what kind of quad I recently got for free. When I looked up the vin all it showed was 2004 and made in China. Any help will greatly appreciated thanks.
       

    • By Rich1028
      We picked up two more quads
       
      We Just Picked up two Quads Friday,and we took them out riding,great machines!
      2008 Honda 400 Ex and a 2014 Honda 400 X 

    • By Hunter19
      How are you doing guys I just joined I have a 1998 Suzuki King quad I’m having problems with high RPMs the ATV idols perfectly but soon as a throttle up it doesn’t stall but it just bogs down it has no power any suggestions thanks
    • By smitht18
      Looking for the rectifier.  Most bikes have near magneto.  It appears the KQ has it in front.
      Can someone tell me exactly where it is? 
      Bike not charging and magneto checks out ok
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...