Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

wayde theriault

Need a little help. (Its Easy, I’m just dumb)

Recommended Posts

 
i need help figuring out how the thumb throttle needs to be screwed in inside the box where the throttle cable is. I can’t figure out how the spring is suppose to sit in there, is there a name for this compartment? Can some link a video or something I’d really appreciate it

if you don’t know what I’m talking about here’s a pic

81A12DD3-86EC-4349-9834-ABDB6435AD5B.jpeg

4DEF4209-9EF5-4200-AD0D-1D75497A4FB7.jpeg

Share this post


Link to post
Share on other sites


There  should  be  a  "hook"  on the  spring  that  clips over the lower  lever  in your  pix, and the other  end  of the  spring likely  just  sits against the  case.   The  longer part with the  hook hooks over the lower lever  arm next to the  bent  down tab of the  upper lever. Here  is a drawing of the assembly :

25376d1441345696-thumb-throttle-assembly

Edited by davefrombc
  • Like 1

Share this post


Link to post
Share on other sites
24 minutes ago, davefrombc said:

There  should  be  a  "hook"  on the  spring  that  clips over the lower  lever  in your  pix, and the other  end  of the  spring likely  just  sits against the  case.   The  longer part with the  hook hooks over the lower lever  arm next to the  bent  down tab of the  upper lever. Here  is a drawing of the assembly :

25376d1441345696-thumb-throttle-assembly

Thanks so much man I really appreciate it!

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Sombeech
      I shot this footage last weekend. We ran a Honda Foreman along the beach and had a great time wakeboarding.
      Helmetcam footage.
      There is also a download link for the YouTube Challenged employees at work.
    • By Eddie Rahm
      whats up fellas....the white wire going from the throttle body came unplugged from the circuit  board and im not sure where it plugs back in to ? i see where the red wire goes but im not sure where the white wire goes...im not even sure what those wires do..any help would be appreciated..thanks. 1996 polaris sportsman 500 4x4 push button awd.
    • By crochet homemade
      I have bought a 1996 suzuki king quad 300 and I have noticed that it smokes but I have put oil in it and plenty of gas had to fix shifter bc the nuts and bolts came out somewhere. I have had to replace the wire for the starter but now when I try to start it it wont idle at all and when it does run it smokes really bad like a whitish blue I guess, and it likes to stall a lot. So anybody can help me out please and thank you

      10000000_310855426253462_714534016610467840_n.mp4
    • By weblex
      Problem: The ATV starts and runs at idle perfectly. But as soon as I open the throttle, the engine starts to slow down until it stops. On the attached video you can hear the sound of how it works: see video below
      Prehistory: there is a Polaris Sportsman 500 1998, which for about 1.5 years stood in repair, including also replacing CDI with one taken from the same ATV. Finally, the vehicles were on wheels, traveled several kilometers and overheated - forgot to fill the antifreeze Came back home in small moves. The next trip started well, but after 10 km there was a feeling of a small drop in power (even as the vehicle got warm completely) but still drives. Next trip - the situation is repeated. The next test of ATV through time and a huge loss of power from the very beginning. The engine sneezes, does not want to go more than 5 mph.

      What has been done: the carburetor has been replaced with a new one (inexpensive, $ 40), a new spark plug, a new ignition coil, the engine head has been removed, the piston is in good condition, valves were corrected - but the problem was definitely not in them.

      Ignition control unit is suspected. Who faced similar? Please help in solving the problem.
      Thanks in advance.
       
       
    • By Tahj
      I lost the brass throttle cable end
      I can't find on cable or carb drawings 
      help
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...