Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

gmoose

2000 Suzuki 500 Quadmaster Fuel Issue

Recommended Posts

Fuel issue. Fuel runs through carb flooding  cylinder when sitting. Does the float suppose to shut the fuel off when sitting ?

Share this post


Link to post
Share on other sites


Topic moved to Suzuki ATV forum and added issue to topic title.

Share this post


Link to post
Share on other sites
On 10/15/2018 at 6:46 PM, gmoose said:

Fuel issue. Fuel runs through carb flooding  cylinder when sitting. Does the float suppose to shut the fuel off when sitting ?

The float is supposed to lift up when the bowl is full and stop fuel flow. If it keeps filling with fuel, you have a carb float issue I believe.

Share this post


Link to post
Share on other sites

It's the needle and seat that are attached to the float actually that is the problem. Take the bowl off, pull the pin that holds the float on, carefully pull it down, check the needle tip for deformation and debris. Take a qtip and place one end in a drill and run the qtip in and out of the seat where the needle sits till its clean. Make sure when it's all reassembled that the float site level when in it's up position. Also with it fully assembled you should be able to blow into the fuel inlet port and air should pass. But if you flip it over and simulate the float being lifted then you should not be able to blow into it. GL

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

    • By jimybud
      Below is a quote from a response to similar question from yesterday: 
      "Easiest thing to check is trash in the main jet.  if it idles fine, then the idle circuit and low speed jet is clear.  if it bogs off idle that's when it's transitioning to the main jet." 
      I will go ahead and open up the carb and check the main jet, but please respond to this post as if the main jet is squeaky clean.
      Below is my post:
      Only starts and runs on Full chock. 
      Does not matter what position I have my "mixture" screw.   Tried it at zero, 1 turn, 2 turn, up to five turns.  Spent a few hours confirming that the position of the mixture screw does not resolve issue.
      Runs great at idle and if I slowly engage throttle, it will rev up as expected.  But, quick rev up or when I am trying to drive it, it spits and sputters and looses power.
      I also use a propane bottle and did not find any obvious leaks, and the vacuum port is hooked to fuel peacock and I also made sure to simply block the port with my finger to see if that would resolve the issue.
      New Carb (after market), New Coil, Fresh Gas.  No leaks at manifold boot, hot battery.  Good gas flow.    Runs too good to be a valve issue, or cylinder, great compression.
      I can move the choke out a tiny bit, and it will still run, but will still bog down when I try to power it up.
      I also have a 250 trail boss Polaris that I require to run at full choke, but it has power at all throttle potions.
      I suspect it is running rich as the choke is on, but will not run with it off.
      Any details would be appreciated.
    • By therealjohnsmith
      I just bought these in the fall as a pair and of course they were running awesome with no problems at that time.
      One of them now will only start with starting fluid. It runs great once it's started, but absolutely refuses to start without a squirt of the good stuff.  The other one starts just fine, but dies after it gets warm. The only way to keep it running is to keep the throttle up. It won't run at an idle, and keeping it running has the throttle too high to shift.  Any ideas or suggestions are very much appreciated!!!
      Thank you,
      John from Shelley, Idaho
    • By mrfartsalot
      I have a 2001 suzuki quadmaster 500 4x4 that has a rev limiter when it is in any gear other than neutral, i have already fixed a bunch of stuff on it and would love to just bypass it if anyone knows how. Thanks for any help.
      video-1583184277.mp4
    • By Mike Johnson
      Hello again guys ,. I have a Quadmaster that has a very bad lean to my passenger side wheel. I replaced the a arm bushings with no change in the lean,  I see no bent parts and no adjustments available. It's always been there since I got it but became really noticeable when I put the lift kit on it. I'm going to add a picture of the problem if allowed.

    • By Stephanie Webb
      please help cant figure out how to bypass rev limiter in my suzuki quad master 500
  • Similar Topics

    • By edb6969
      View File 1999-Later Honda TRX400EX Carb/Cable Removal
      1999 - Later Honda TRX400EX Carb/Cable Removal Supplement
      Submitter edb6969 Submitted 11/02/2020 Category Honda ATV  
    • By Kelby 746
      Hey y’all I got a kfx 400, rebuilt the carb put bigger inlets on it, adjusted the fuel mixture screw 2.5 turns out and cleaned the fuel petcock. It starts up not so great, it takes full throttle with full choke and cranks for about 10-20 seconds before it fires and while “ideling” it surges very bad and I’ve messed with the idle set and it changes nothing, if you ride it casually it runs fine but as soon as you get on it for more than 4 seconds it stumbles and falls flat on its face and you have to wait for the carb to fill back up with fuel, I’ve checked everything and nothing is blocking fuel, I even put a bigger hose to see if that made a difference. Thanks for reading hopping to hear someone has some advice. 
    • By Michael Rogers
      Well this is my first time tearing down an ATV. Have done a little work on 2 stroke's in the past, but not much. I'm needing some help. I've got a Bayou that has lost compression. I tested it, and it was like at 40psi. I had already set the timing on it, and it does have spark fuel, etc...
      My question is about the cylinder. To me it looks pretty toasted, but need some help in determining. It is a 2000 Kawasaki Bayou 220. I bought it not running, just to see if I can get it running so it has not ran since I bought it. This question is about the cylinder, and part 2 I have will be about the CAM.
      Any advice / help is greatly appreciated.
      Inside sleeve a line(left line) runs the length that I can feel with my fingernail. The line on the right I can't feel.

       
      Some rust it looks like on these two pictures.
       

      Thanks!
    • By erk mann
      What is the trick to remove the carburetor  on a 1987 moto4 350? 

    • By Halley
      Could anyone take a look at the picture and let me know if I’m needing to replace the actual throttle cable or the throttle handle ? Its for a can am 2018 outlander XMR 1000. It’s in limp home mode and throwing code P1619


  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...