Quantcast
Jump to content


QUADCRAZY Time Machine


Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By Frank Angerano
      So I decided to pick up a small trailer if I could get one for the right price.  I found this one for a few hundred bucks on Craig’s list.  It is  a galvanized trailer which is exactly what I was looking for. The wood was shot and needed some minor repairs which I could care less about as long as the chassis was good. 
      I striped it down and put a new deck on. I had some vinyl realtree graphics that I had laying around so I added them to the fenders which I think worked out well. Very happy with this little guy.  
      I'm having the iron workers at my jobmake me up a few lightweight side rails that will have a 22 degree bend in them to accommodate the tires that slightly hang over the edge and will incorporate some tie down points as well. 








    • By Whiterabbit
      New to me Quest 650 with the Rotax engine, auto trans. Looking at the starter solenoid there are the usual wires, Batt+ in and Batt+ out to starter and the 2 lil wires to the ign start button but there is a factory box with 2 lil wires coming out mounted to the frame next to it, one wire is connected to one of the large Batt terminals (12 o-clock position in pic). The other wire from the box is just dangling out in space. I can't find where that loose wire goes and what the **** the lil' box is. 😆 Need some insight please.
       


    • By spuukii
      Hey everyone, recent new-to-me ATV owner/rider.

      I have a 2003 Bombardier 650 4x4 Quest and recently my speedo just decided to stop working. The odometer doesn't tick up either but that makes sense considering it thinks I'm going 0mph all the time. I found some links online that mentioned there was a speed sensor to the right of the oil dip but after taking it apart I didn't see anything that looked like what Google images says a speed sensor would be.

      The speedo itself moves to 0mph from the off position when turning it on, the backlight for the speedo turns on, and I can switch between trip mileage and hours. The machine itself rides fine as far as I can tell with no bad effects from it. I tried to find a service manual online but it linked me to a bunch of shady sites and I wasn't trying to get scammed out of $15 each until I find one that is actually legit.

      Has anyone had a similar issue and knows what the fix would be, or where I should actually be looking for the speed sensor? Or at least point me towards a reputable site for a service manual that might better explain where/what to look for?
    • By Mcsful8er
      Just picked up a 95 Polaris trailblazer 250, needs a little work but he’s pretty stoked
    • By psychodad
      Just rebuilt a 2006 Yamaha Big Bear carb for a friend and would like to double check the float height before I give it back to him  Anyone have a manual they could look it up in or a really good memory. 
      Thanks
      Jim
×
×
  • Create New...