Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Paul Muscat

Kymco Mongoose 250cc rear rims

Recommended Posts

Hi all, I own a kymco mongoose 250cc. One of the rear rims is quiet damaged in fact it wobbles while spinning.  Does anyone knows a good website where I can buy a rim as the one in the picture.  

Thanks

48388467_532661243882239_1358287766751805440_n.jpg

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By BuckBilly
      Good morning to all !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
      Let's see if we can make this a daily event.
    • By Alois Specht
      Hi there , have a KAZUMA 500 JAGUAR the rear diff is permanently locked , how can I get it out of lock just about tried everything I think, ?? .  Thank you your help is appreciated.
       
    • By Kevin Nicoll
      Anyone familiar with these models? Its a new to me quad, picked it up for basically nothing... Just time and materials now, this looks expensive. 




    • By dbconn55
      Hi guys I have a 2003 Arctic 250 4X4 it starts idles and runs great for about 10 min. then it spits and sputters and dies but it starts right up like nothing happened idles good till you give gas and it does it again let off the gas and it's idling great again this goes on for about 15 to 20 min. and then it takes off runs good all day like nothing was wrong.
      I cleaned the carburetor it looked like a new one inside found a little gunk in one orifice, new air filter no crimped lines air line to tank good I did put a meter on the battery idling it said 16.5 V that's high I think would a voltage regulator cause this?
      Suzuki shop wanted to sale me a stator for $556.00 but said it could be something else also thought I'd see what you guys say about it
      Thanks
    • By caperwing
      The rear brakes on this are hydraulic and manual. The hydraulic part is all messed up so I disconnected it all and want to go just manual on the rear. I got it all put back together but doesn't seem to work to well, like not enough pressure. The manual says I should mark the casing before taking it apart which I didn't read until to late. Any ideas? I put new brake pads on.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...