Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

steve1

Working on my 800 Hisun

Recommended Posts

Hi people ...I am thinking I will prob spend the next 12 months solid on here trying to get my 800 Hisun working right but that is life I guess....it all started when a very large lady sat on me in the bus when I was three...and things havent got any better since...my poor old 800 is pretty crook ...fuel wise and gearbox wise as well. I went on the net and saw a heck of a lot of posts from guys that are really enthusiastic about theirs and I thought  wow they cant be all bad...so maybe I can pickup some tips from your forum posts....I am currently removing millions of screws from the body to access everything and then I guess I will see if anyone has worked out the wiring and devised some tests....back to the screwdriver for now...

  • Haha 1

Share this post


Link to post
Share on other sites


@steve1 Welcome to QUADCRAZY, I change your topic title from "steve" to "Working on my 800 Hisun", this way members have an idea of what the topic is about 🙂

  • Like 1

Share this post


Link to post
Share on other sites

And the pile of screws gets bigger and bigger...I have never seen so many plastic panels....the beast within is slowly being revealed. Sure makes it easier once the roll bar and roof section come off....it does not make it any easier having a two and a half month old great dane puppy running off with half of the stuff I have taken off....

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By David Terzian
      Hi, Name is Dave, I am new to the site. I have UTV 2018 Textron Stampede... cant get the 4 wheel drive to work.
      I recently had blown out the fuse for the acc... while hooking up my turn signals,,, and ever since then
      4 wheel drive doesn't work, I can lock in the rear,,, while having the key on motor off,, I can hear the clicking
      sound,, which sounds like a relay in the rear... but when I switch to 4 wheel drive, I hear nothing. shows up on
      the dash that its working, anyone can help would be greatly appreciated. All Fuses and relays under hood are
      good, and under rear seat. Thanks  Dave 
    • By fox300exchic
      Let's hear all there is to know about you ladies! Where your from and where you've lived. Kids or no kids. What you do for a living. Why you ride and how you got started.
    • By Stacy Hanks
      I have  2000 Yamaha bear tracker 250 - igniton relay and starter relay both were replaced also the neutral switch indicator was replaced-- bike will not show light on for neutral or start when button is pushed
       
    • By DrtyGrlKristin
      I'm curious what all the ladies ride on this site and why!
      I ride a 2008 Yamaha Rhino 700. Just added a new roll cage, dual exhaust and some other things. Here are a few pics:


      I chose the Rhino because my arms and wrists get way too tired on a quad. I haven't tried a bike, but, I don't think my coordination would be good enough to handle that!
      I LOVE my Rhino though!!!!!!! It's the perfect machine for me.
      So, how about you????
    • By Trenton
      Hello. I am a new member as of today. I had a quick question to ask. I recently was driving mt HONDA RANCHER 2004 GPSscape 400 and my display stopped working. I was driving the atv and all of a sudden the speedometer and the service lights went out. Also the lights stopped working. I am still able to shift gears, change from 2wd to 4wd, and can still select if I want EPS or Auto. I have checked my fuse box and have changed a few of them around. It did not change anything. I was wondering if anyone had any idea of what had happend. Thank you for your time- Trenton 
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...