Quantcast
Jump to content

STOLEN ATV: Stolen Polaris Xplorer


StolenATV

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By exalrod
      Hi Everyone,
      I recently purchased a 2005 50cc Polaris Predator for my granddaughter.
      The wiring is a mess. most of it appears to be jumpered out (twisted together).
      I installed a new carburetor. The gas tank was cracked so I found another one on ebay and got that installed. There is no air filter box. I ordered another one but, it has not arrived yet.
      I did get it cranked with the kick start. But, it idles too fast and when you give it any throttle the motor dies off. The more throttle you give it the faster it dies off. It is very hard to start when it has not been running for a while. However, once it has warmed up, it starts on the first kick every time after that.
      I am looking for a little assistance in getting it running better and also a wiring diagram and service manual if possible.
      Thanks in advance....
       
    • By Johnfj44
      The stock driver seat cushion is separated at a seam. I took the seat apart and found that the material has torn and cannot be re-stiched. I'm trying to find a replacement seat. Any suggestions? Hoping for a used seat but couldn't find one on Ebay.
    • By Werewolf
      Oil is getting in the air box from crankcase vent tube, I put the two hoses that go to the air box together then something started to smoke on the front of the engine. There is a filter? In the line I blew that out.
    • By JohnnyB
      Greetings, 
      Have a 88 LT80 that been sitting for a couple years. Bought a new piston, cylinder and head. Installed these, rolled it over and it quickly locks up.  Took carb apart. It was full of what appears to be 2 cycle oil. Cleaned it, but keeps locking up and 2 cycle oil continues to seap from exhaust port.  When i installed new cylinder, I noticed crankcase was full of oil.  I'm now wondering if that oil is what's getting sucked up into cylinder.  Should there be no oil in crankcase?  If that the case, how is crank and rod lubricated?  Sorry, never worked on a 2 stroke. Thanks!
    • By Spritee1
      having an issue with the unit when running under a load up a hill or in high gear, seems like the belt is slipping, there is a clapping sound coming from the primary clutch like it releases and snaps back in. i don't think I should have a noise like that. this is a friends unit and he has already replaced the primary twice with the same result.
      not sure where to look next
×
×
  • Create New...