Quantcast
Jump to content

STOLEN ATV: 2006 Honda Foreman 500 Stolen From my Property


StolenATV

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By Arizona
      I recently bought a 87 TRX 250 not running of course, the owner had a brand new Key Switch on it.
      I think it is the wrong one or wrong wire colors as the colors dont match up with wiring diagram i downloaded for it. 
      anyone have a pic of their ign switch wires where they connect with the wire colors for that model? I ended up leaving the black/w stripe and
      green wire disconnected in order to hot wire it for other testing but would like to know as the colors dont match diagram. 


    • By TheRetiredMilitaryGuy
      Hey y’all, I need some help badly. I have a 02 Honda foreman rubicon 500, it sat for a year (ran out of time) just did a full top end plus piston and rings on it. Got it running but it will not drive forward at all and will only do 2 mph in reverse. The engine or transmission makes a very loud whining when I hit throttle both ways. 
      I need some help I’m very unfamiliar with the hondamatic. 
       
      Any ideas or options?
    • By Werewolf
      Oil is getting in the air box from crankcase vent tube, I put the two hoses that go to the air box together then something started to smoke on the front of the engine. There is a filter? In the line I blew that out.
    • By JohnnyB
      Greetings, 
      Have a 88 LT80 that been sitting for a couple years. Bought a new piston, cylinder and head. Installed these, rolled it over and it quickly locks up.  Took carb apart. It was full of what appears to be 2 cycle oil. Cleaned it, but keeps locking up and 2 cycle oil continues to seap from exhaust port.  When i installed new cylinder, I noticed crankcase was full of oil.  I'm now wondering if that oil is what's getting sucked up into cylinder.  Should there be no oil in crankcase?  If that the case, how is crank and rod lubricated?  Sorry, never worked on a 2 stroke. Thanks!
    • By Spritee1
      having an issue with the unit when running under a load up a hill or in high gear, seems like the belt is slipping, there is a clapping sound coming from the primary clutch like it releases and snaps back in. i don't think I should have a noise like that. this is a friends unit and he has already replaced the primary twice with the same result.
      not sure where to look next
×
×
  • Create New...