Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

gooseman80

WTB: ITP AT589 M&S 28x9-12

Recommended Posts

I need a replacment ITP AT589 M&S 28x9-12. The problem is that I have a defective tire right now with a slight bulge causing a wobbing with the bike. I know my chances are not good considering how long the tire has been discontinued but it never hurts to try. Thanks

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By BuckBilly
      Good morning to all !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
      Let's see if we can make this a daily event.
    • By Brent Wright
      What's a good size to start a 10 year old on?
    • By Jeff Miller
      I'm trying to troubleshoot a starting issue. For a while, maybe a year sometimes I would hit the starter button and I'd hear a single loud click, but the starter wouldn't turn. Usually if I could pull the pull start or roll it in gear it would then start. (now I'm thinking that was coincidence) Now it only clicks. I tried to check what I could, battery is good, solenoid clicks strong, cleaned all connections (which were 80% clean anyway). I started thinking the starter wasn't spinning. I pulled it and it spins freely. The gear that it contacts in the engine-I can wiggle it maybe 1/16th to 1/8th inch back and forth. When I reinstall the starter I feel it jerk when I hit the button. I'm thinking maybe it's the starter clutch? It seems when there's a problem with them they usually just spin freely and don't engage at all. Is it possibly something is causing it to lock? I'm a bit lost now.
    • By Outkast7222
      Well been lurking for a couple years, figured its time to say hey! Been riding in MN since the early 80's been on just about anything and everything with a motor. If you are from the area hit me up! Currently riding a 2018 Sportsman XP 1000, but thinking of going to a General or possibly a Maverick Trail.
    • By Gilbey
      Does everyone run the tire pressure as stated on tires or perhaps a couple # below to soften the ride a little?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...