Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Kartmanz W

Just saying Hi

Recommended Posts

Just wanted to say Hi,

Ive got a quadrunner LT250 which I'm hoping to get up and running (She runs but a little smokey!) properly, so to have a forum like this is amazing!

 

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Randel1
      I'm on to the next project. I am trying to put a 1994 Suzuki 250 2X4 quad runner back into service. I am currently going thru the fuel system and am waiting on some parts. In the meantime I have been trying to locate replacement fenders and I'm not having much luck.  The orriginal fenders have become brittle and cracked due to sun and exposure to the elements. Any help on finding replacement fenders, OEM or aftermarket, will be appreciated.
       
    • By pablo Blake
      Its in pretty rough shape and its gonna be my first atv, I worked on bikes before but nothing to do with quads. Anyways the quad has some problems and im tryna figure out what to focus on first. So the U joints i think are shot. The bike starts first try every time ussually have to give it a lil gas with the throttle and revs right up, idles fine but its running REALLY rich 3 starts and my brand new plug was pitch black

      Bike is L model

      video-1577465068.mp4

      Its using the original mikuni carb but im not the best at fixing the carbs and wondering if there is anywhere online that would be able to either walk me through it or help me with it i didnt see a air mixture screw so it seems like im gonna half to open it up and adjust like the float and a couple other things
    • By BAMFUPINYA
      Any current Northern AZ folks out there on this forum? Im up in Flagstaff. Any organized rides anyone knows of?
    • By oliverstevenrjr
      I have a 425 Magnum that idles great but seems to flood out when I rev it up, sputters, backfires a little somtimes. No water in gas, good fuel filter, carb seems to be fine, good working diaphram. Plug change makes no difference whatsoever.
    • By Quadrunner44
      I have an older 1980s Suzuki quadrunner red lt 4wd (250)
      so just finished putting it all back together and was running fine just needed to adjust the rebuilt carb
      bf decides to hook up an air chuck to the gas tank because it got a shot of air in the gas line well 120psi didn’t agree with any of the parts including the new carb 
      end result : new battery new carb now it just clicks (one single click) won’t turn over 
      hard to pull start gets hung up (unless I remove the spark plug ) gas flooded out the first time but now does nothing purchases a new starter waiting the arrival 
      could there be damage to the crank shaft or pistons etc? Or install the new starter and try to fire it up ? What caused the starter to die after he flooded everything with gas was working fine. 
      Thank you 
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...