Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Kartmanz W

Just saying Hi

Recommended Posts

Just wanted to say Hi,

Ive got a quadrunner LT250 which I'm hoping to get up and running (She runs but a little smokey!) properly, so to have a forum like this is amazing!

 

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Chrism
      Hi all, new to this forum so thanks in advance for the help.

      I have recently brought a 2013 power steering fuel injected foreman 500.

      It has a crack in the front casing and was running rough. I have since replaced the front engine casing and this has made no difference to the engine performance.

      It starts and idles but bogs down and starts to die once throttle is applied.

      It maybe be but it also sounds very load.

      I have uploaded a video link of it.
       
       
       
    • By JonBat68
      I have a 99 250 Quadrunner. Currently has no spark. It would run for 5 minutes, then shut off. After it cooled down about 20-30 minutes, it would start again. I ordered a new stator and found the old one was damaged (copper windings broken)  I installed the new stator, filled with oil and now it has no spark. Any assistance would be helpful
    • By donerightautomotive84
      Ok so 2000 sportsman new.caltric carb new fuel pump new jug and piston new cdi and coil finally get to start it and itll idep for 5 to 10 seconds and die what am i missing people any help id love ya forever lol
      Sent from my LM-Q720 using Tapatalk
    • By Dskip160
      Hey there! New guy here! So I bought an 87 250. I turn the key and it has ignition light. I press run and the engine turns over. Guy I bought it from said the carbs may need cleaning, I worked them good cleaned and blown out. I reinstalled the carb and still doing the same thing. It’s getting fuel, the battery is brand new and charged I’m lost here!( purchased a new carb on its way) anyone have any ideas

    • By pablo Blake
      Its in pretty rough shape and its gonna be my first atv, I worked on bikes before but nothing to do with quads. Anyways the quad has some problems and im tryna figure out what to focus on first. So the U joints i think are shot. The bike starts first try every time ussually have to give it a lil gas with the throttle and revs right up, idles fine but its running REALLY rich 3 starts and my brand new plug was pitch black

      Bike is L model

      video-1577465068.mp4

      Its using the original mikuni carb but im not the best at fixing the carbs and wondering if there is anywhere online that would be able to either walk me through it or help me with it i didnt see a air mixture screw so it seems like im gonna half to open it up and adjust like the float and a couple other things
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...