Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

2011 Crown Vic here with 305k miles, and today my engine light comes on. Scan at the local Advanced comes up with 4 codes on the cat converter. Guy says I need to get something called Cataclean and run it through the gas tank to correct the problem.


Is it worth doing this...will it make the engine run better or get better gas mileage?


Should I use Cataclean or some other product to get this done?

Share this post


Link to post
Share on other sites

Cataclean doesn't always work and if there is an underlying issue it will not solve your problem. But, its a cheap "worth a try". What are the codes that came up? 

Share this post


Link to post
Share on other sites

Sorry it took so long to get back. The check engine light went off but it came back on yesterday so I got the codes read again. Guy's machine read 4 codes but said they were all the same code...P0430.

I'm game for the lacquer thinner option I've been hearing about. I see low voc lacquer thinner for sale. Wonder if it matters which version you use?
 

Share this post


Link to post
Share on other sites

Did the light come off on its own or was it cleared? That code can be a bad converter but can also be some other things:

https://www.autocodes.com/p0430_ford.html

Possible causes Faulty Three-way Catalyst Converter Bank 2 Exhaust Tube Intake Air Leaks Faulty Oxygen (O2) Sensor Faulty Fuel injector(s) Leaking Fuel Injector (s) Faulty Spark plugs Improper Ignition Timing Faulty Engine Control Module (ECM) Dirty Air Filter

Tech notes As the code description implies the P0430 code means that the vehicle's control module has detected that the three-way catalytic converter is not working properly (is not as efficient as the factory is expecting). Replacing the oxygen (O2) sensors may sometimes fix the code, but in most cases the catalytic convert needs to be replaced to fix the problem. If the P0430 code is combined with other codes, try fixing the other codes first. 
 

 

Share this post


Link to post
Share on other sites

Thanks EC.  Great info in that video there.

The check engine light went off (dark) on it's own after being on for only a couple days.  After staying off for maybe another 2-3 days it came back on again.

Have advice it might be my intake manifold leaking, but it was replaced new w/ OEM last year so that's probably not it.

New plugs as well.

I'll go ahead and replace the air filter just to make sure.

Also, the engine takes about a quart of oil every 1000 miles or so.  I don't see any drips in the driveway but I don't see any smoke from the exhaust either.  Not sure where the oil is going.  I was assuming it was leaking out only when it's being driven.  Been told if it's burning oil that could be causing this code as well.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By VikingTrad3r
      picked up my third timberwolf 250 for my daughters.  these are great light weight little quads.
       
      have a strange one for you.  the quad will NOT start in neutral.  it will start in first. 
      if i lift up on the gear selector just enough to hear the little click (its not loud, sounds like a contact clicking, perhaps the neutral safety switch?) the light will go out, but it won't yet be in first either.  that is how i have shown my daughter to start it and she can.
       
      id like to carry out whatever repair is needed.  i have the pdf of the shop manual but it doesn't really have a flow through diagram.
       
      any help appreciated!  thank you.
      i need to add something.  it feels like i can switch into another gear BELOW neutral.  
      so if i switch to neutral, i can keep pushing the gear selector, and it has another click below the neutral.  the light stays on, and when i pull up into first it kind of feels like it has two positions it moves through to arrive at first.
    • By technofarmer
      Hey there, i have recently put a new drive belt on my 11 Polaris Sportsman 500 H.O.    It has 44 miles since putting the new belt on and should be nearly broken in as i hear it takes 50 miles to do so?  Anyhow it has had a little trouble with slipping since i put the new one on a few months ago. Now whenver i go down a hill the belt seems to be getting caught in one clutch if not both and then it has to run a high rpm just to go a low speed.  Today it did that again going down hill, i stopped, put it in neutral and when going back up the hill i had to turn it off, put it in neutral, let it roll back down the hill a little, then restart it, low range and it was slipping but thankfully i was able to make it up the hill. 
       
       So what might the problem be? Is this a need for another new belt? New clutches and belt? Or just get something else? BTW the brand new belt i put on it, is a factory one, an exact replacement for the original.   

    • By Airborne
      Just got home from voting, this is about the most i will talk politics lol....for the fact that im hoping America gets back to the way things used to be , just my opinion but America seems so much more angrier, im burned out 2020 has been very political and im ready to move forward , im 54 been voting since 18 and have never seen an election like this ...okay Enough ! Lol 
      Dump the masks ,and lets focus on America moving forward ...ugh lets grab a cold Beer and laugh again ......just my 2 cents 🇺🇸😊
    • By Airborne
      Well here we go ... snowing like crazy front lawn covered already lol i guess winter is here , time to set plow up. 
      Last weekend i built a concrete ramp for bringing machines into basement , glad i got that done lol. Wouldnt be doing this weekend. 
      Be safe guysm
    • By dpacapt
      Has anyone disabled the engine brake on their atv, or is it even possible?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...