Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
StolenATV

STOLEN ATV: Stolen 2004 Suzuki LT-Z400 – White

Recommended Posts


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By ronald webb
      So where to start my son's LT80 stop running a couple months ago. Naturally I assumed I had a carburetor issues or the peacock valve. After replacing those two items and ensuring I had a spark I started doing my homework thus finding this page. After all the post I have read the next natural thing would be compression I did a compression test today and it was only 60 after spraying WD-40 in it so off comes the cylinder head and The Jug to my surprise the cylinder walls and all the gaskets are pristine so I am totally stumped no idea why I would not have compression when everything looks brand new even the Rings look great any help would be appreciated thanks in advance
    • By JonBat68
      I have a 99 250 Quadrunner. Currently has no spark. It would run for 5 minutes, then shut off. After it cooled down about 20-30 minutes, it would start again. I ordered a new stator and found the old one was damaged (copper windings broken)  I installed the new stator, filled with oil and now it has no spark. Any assistance would be helpful
    • By DMC66
      I need a repair manual for a 2004 and a 2005 sportsman 90 and I found a 2006 manual for cheap money. Is it worth getting and will it cover everything for the 04 and 05
    • By JacobSlabach
      So yesterday I picked up a 07 polaris sportsman 800efi stealth edition for 3k.  Will lead a pic ltr.  In good shape.  Here's what's wrong with it:
      The rpm needle doesn't work just like my other sportsman... not too worried ab that.
      The motor doesn't sound like it's running quite right and doesn't feel like it has much more power than my 500.  I'm thinking it needs a tune up and some fresh oil..  but also it feels like it's running rich.  It's a little buggy when you goose the throttle and sometimes farts when you let off (like I little backfire out the exhuast). I'm gonna check timing and valave clearence on the motor first but thinking of putting a tuner on it? Anybody got a suggestion?  Mainly looking for more power.
    • By KDawgFPC
      I have a 2004  Kawasaki KLF300. I’m not sure What is the black/yellow, brown, and red wire wrapped together in the wire hornets of a klf300. I got it used and notice some wires not connected. They are located in the front area 

      The reason why I am asking because I’m having issues with it firing up. I cleaned the carb put new spark plugs and gas. 
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...