Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
StolenATV

STOLEN ATV: Stolen 2004 Suzuki LTZ 400

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By mjm4jc
      Hello eeveryone,
      Just picked up an 86 Suzuki LT185 for my daughter, and she's complaining that it bounces so bad over bumps that it nearly throws her off the quad. I have the tire pressures some where around 3 psi. I really can't go any lower than that. I noticed that there isn't anything in the aftermarket world for shocks and springs for this quad. I am wondering what others are doing to soften up the ride. Also wondering if there's a way to fabricate a rear shock, since there isn't one.  I appreciate your feedback.
      Thanks!
    • By Ajmboy
      View File 1984-1987 Suzuki LT185 Service Manual
      1984-1987 Suzuki LT185 Service and Repair Manual
      Submitter Ajmboy Submitted 09/13/2020 Category Suzuki ATV  
    • By Brent Wright
      I've cleaned the carb.still didnt fix.any suggestions?
    • By fishinnnc
      I just bought this thing and got the carb all cleaned today and it was running like a champ. There was a spare hot wire hanging down that was not hooked up to anything. I found it when I took all the covers off and did the carb work. Unfortunately I forgot it as well when I fired her up after cleaning and replacing the carb. While I was running her, the wire was lying across the exhaust pipe. The exhaust got hot, melted the insulation and next thing I know I see sparks flying everywhere Bike immediately shut down and all lights went off. I have nothing on the console now when I turn the key over. I fear I have fried my ECU. I found one fuse back by the box, a 30 amp, but it was good. Are there any other fuses on these things? Is there a way to test the ECU? Could it be the rectifier or voltage regulator?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...