Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
StolenATV

STOLEN ATV: Stolen Golf Cart

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By Airborne
      Hey Guys/Gals
      going into my second year on new quad , my kodiak is everything and more then expected ; wife loves hers as well. We got the 450 and 700 ... made sales guy smile when we ordered two ... the question i have is the tires , i have heard many say aftermarkets are just much better , iwe use our machines in woods ,and trails and we do ride in snow, with that i think my stock tires suck.  The have plenty of tread left but i just think i could be happier with better tires ........id love comments and input 
    • By jimybud
      Below is a quote from a response to similar question from yesterday: 
      "Easiest thing to check is trash in the main jet.  if it idles fine, then the idle circuit and low speed jet is clear.  if it bogs off idle that's when it's transitioning to the main jet." 
      I will go ahead and open up the carb and check the main jet, but please respond to this post as if the main jet is squeaky clean.
      Below is my post:
      Only starts and runs on Full chock. 
      Does not matter what position I have my "mixture" screw.   Tried it at zero, 1 turn, 2 turn, up to five turns.  Spent a few hours confirming that the position of the mixture screw does not resolve issue.
      Runs great at idle and if I slowly engage throttle, it will rev up as expected.  But, quick rev up or when I am trying to drive it, it spits and sputters and looses power.
      I also use a propane bottle and did not find any obvious leaks, and the vacuum port is hooked to fuel peacock and I also made sure to simply block the port with my finger to see if that would resolve the issue.
      New Carb (after market), New Coil, Fresh Gas.  No leaks at manifold boot, hot battery.  Good gas flow.    Runs too good to be a valve issue, or cylinder, great compression.
      I can move the choke out a tiny bit, and it will still run, but will still bog down when I try to power it up.
      I also have a 250 trail boss Polaris that I require to run at full choke, but it has power at all throttle potions.
      I suspect it is running rich as the choke is on, but will not run with it off.
      Any details would be appreciated.
    • By BUKNDUK
      Hello 
      I want to paint the body on my 1999 Suzuki King Quad 300. The original color is Tan. Does anyone have any experience in painting smooth plastic. What preparations need to be done,maybe sand body to ruff it up so paint sticks or some type of chemical cleaner also can you please recommend the correct paint I need I would think something flexible 
      Thanks
    • By michaelnewell
      I took front brakes apart recently and found pistons frozen in calipers. Havent been able to find cheap calipers for this bike
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...