Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
StolenATV

STOLEN ATV: 2015 Yamaha YFZ450R Stolen During Test Drive

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By JacobSlabach
      So yesterday I picked up a 07 polaris sportsman 800efi stealth edition for 3k.  Will lead a pic ltr.  In good shape.  Here's what's wrong with it:
      The rpm needle doesn't work just like my other sportsman... not too worried ab that.
      The motor doesn't sound like it's running quite right and doesn't feel like it has much more power than my 500.  I'm thinking it needs a tune up and some fresh oil..  but also it feels like it's running rich.  It's a little buggy when you goose the throttle and sometimes farts when you let off (like I little backfire out the exhuast). I'm gonna check timing and valave clearence on the motor first but thinking of putting a tuner on it? Anybody got a suggestion?  Mainly looking for more power.
    • By Airborne
      Hey guys been member for awhile and love this group ,kind of lost contact with social media ,i have been so busy working my property and just Racing the calender while winter is creeping in , i even slacked off Fly fishing this season , 
      As we know winter sets in and time becomes available lol, i have plenty of silly “ Quad stories to share as well as just missing the guys here great group , looking forward to winter break and tying some flys lol.     
    • By AtvNewbie
      Can somebody help me on my issues? i bought new stator for my 1987 big bear 350 4x4, (1) it seems that the old owner replace the pickup coil with same color aftermarket pickup coil, i got no idea which pickup coil goes where on 2 spot, new stator have the right colored wire for each pickup coil btw, 
      (2) new stator got brown and green wire connecting  to cdi but my cdi got brown and red, anybody got idea if brown go to brown and green go to red? Thanks
    • By jimybud
      Below is a quote from a response to similar question from yesterday: 
      "Easiest thing to check is trash in the main jet.  if it idles fine, then the idle circuit and low speed jet is clear.  if it bogs off idle that's when it's transitioning to the main jet." 
      I will go ahead and open up the carb and check the main jet, but please respond to this post as if the main jet is squeaky clean.
      Below is my post:
      Only starts and runs on Full chock. 
      Does not matter what position I have my "mixture" screw.   Tried it at zero, 1 turn, 2 turn, up to five turns.  Spent a few hours confirming that the position of the mixture screw does not resolve issue.
      Runs great at idle and if I slowly engage throttle, it will rev up as expected.  But, quick rev up or when I am trying to drive it, it spits and sputters and looses power.
      I also use a propane bottle and did not find any obvious leaks, and the vacuum port is hooked to fuel peacock and I also made sure to simply block the port with my finger to see if that would resolve the issue.
      New Carb (after market), New Coil, Fresh Gas.  No leaks at manifold boot, hot battery.  Good gas flow.    Runs too good to be a valve issue, or cylinder, great compression.
      I can move the choke out a tiny bit, and it will still run, but will still bog down when I try to power it up.
      I also have a 250 trail boss Polaris that I require to run at full choke, but it has power at all throttle potions.
      I suspect it is running rich as the choke is on, but will not run with it off.
      Any details would be appreciated.
    • By erk mann
      What is the trick to remove the carburetor  on a 1987 moto4 350? 

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...