Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
StolenATV

STOLEN ATV: 2003 Yamaha 660 Raptor and 2014 Honda Foreman 500

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By Ryan Lewis
      Went on a great ride on Sunday from the M-33 trail head to the Lupton trailhead in the Huron National Forest.

      More videos from the ride to be uploaded to the channel soon.
       
    • By Asen_77
      Hi All,
      My name is Asen and I am from Eastern Europe, Bulgaria. Riding a Yamaha Raptor 700R and this is my first Quad wanted for a vey long time :)

       
    • By wayde theriault
      Hello, I just bought a 2006 ttr125 and the guy said it needed a new carb because gas was leaking out the overflow and he couldn’t find out what was wrong with it, I opened it up and messed with the float and I couldn’t figure it out myself so I just ordered a $30 carb off of amazon. I installed it and it seemed to run great around the yard but when I got on the road and started picking up speed it seems to just turn off once I slow down and down shift. I don’t know it’s like if I go to fast it will just completely die and right after it dies it won’t start, the es won’t work nor will the kick start, I have to wait a good 30 minutes before I can start it and it runs fine again. Anything helps! Thanks    
    • By Tinscissors 428
      I have a 01 blaster kickstart won’t work but bump start does work
    • By Ajmboy
      Unfortunately I didn't notice some of the rust hitting the undercarriage of my 2004 Yamaha Grizzly 660, but saw it the other day when I was doing some maintenance, oil change, air filter, spark plug, etc. The left side footrest broke and that's causing the plastic to hit the front wheel. It broke right at the welds from too much rust. Looks to me like what I need is (looked this up on yamahapartshouse.com):
      YAMAHA FOOTREST BOARD 5KM-27481-10 Left side (broken)
      YAMAHA FOOTREST BOARD 5KM-27488-10-00 Right side (rusted and will probably break eventually)

       
      Does anyone have a less expensive source? I did see on ebay a couple of listings but it still comes out to @ $50 each, 
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...