Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Colin James Krepela

350 Avenger 4X4 Shaft Driven OLD NEED HELP

Recommended Posts

So here's the deal people, I have an old Avenger 350 4X4 Shaft Driven ATV. They only made them in the early 80's their thought of as the first four wheelers from around back when Suzuki made one in 1982. I believe the engine on it is a Kohler as I watched this video https://www.bing.com/videos/search?q=avenger+400+atv&view=detail&mid=1E10E939019CA07770031E10E939019CA0777003&FORM=VIRE but mine is a 350. That's if its original, and it all looks original. I am wondering where I can get parts for this engine, or really what engine is it. I have no way to find the year, unless you guys know where a serial number might be. Every sticker is worn off. IF anyone has any information at all on these old wheelers it would be greatly appreciated. I specifically need the gaskets for the carb, and don't tell me I could build them please I want to restore it as perfectly as I can. I can take pictures of the wheeler/carb if it'll help. Let me know.

Share this post


Link to post
Share on other sites


I totally appreciate your willingness to help me and I apologize for taking to long to repost but I was out of town hunting. Its a Mukini Carb and I believe a Kawasaki KF82 Engine in it. I still need to figure out the brakes the drum has nothing outside of it if you have any advice. 

Share this post


Link to post
Share on other sites

Definitely post some pics of all the problem areas including the carburetor  as well as looking along the frame for any vin# hopefully something is stamped in the frame someplace. My guess is it would be located under the front plastics on the frame where the down tubes are. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By mkibbe
      My 2014 750 king quad stalls sometimes when I touch or turn the handlebars,the problem has gotten worse,my machine has 475 miles and is only trail ridden,I have a new factory battery and i have 14.2 volts when the quad is running and 13.3 on the battery when not running,also using a multimeter there is no change in volts when turning the bars until it does stall,If I pull the 40 amp power steering fuse it will not stall.......I've been told its the ECU,Hate to buy one if thats not the problem,but its kinda leaning towards that,,,,,need some opinions.

    • By mjm4jc
      Hello eeveryone,
      Just picked up an 86 Suzuki LT185 for my daughter, and she's complaining that it bounces so bad over bumps that it nearly throws her off the quad. I have the tire pressures some where around 3 psi. I really can't go any lower than that. I noticed that there isn't anything in the aftermarket world for shocks and springs for this quad. I am wondering what others are doing to soften up the ride. Also wondering if there's a way to fabricate a rear shock, since there isn't one.  I appreciate your feedback.
      Thanks!
    • By Ajmboy
      View File 1984-1987 Suzuki LT185 Service Manual
      1984-1987 Suzuki LT185 Service and Repair Manual
      Submitter Ajmboy Submitted 09/13/2020 Category Suzuki ATV  
    • By Brent Wright
      I give it gas then it dies.any advice to fix?
    • By Venom
      I am working on a friends 2006 Suzuki LT-Z50 that they purchased not running. I took apart the carb to rebuild it and someone had already been in there... They really destroyed the Air/Fuel Mixture opening in the body of the carb.. It is in no way repairable.
      I have not been able to find an aftermarket carb to fit this model.
      Does anyone know if an aftermarket carb is available?
      Thanks for any help.
  • Similar Tagged Content

    • By Nate Hanson
      I am a new atv owner...I bought a used atv this summer (pretty sure it is a wolverine but reg card from last owner didnt actually say that so idk for sure). It ran great for most the summer and early fall but one day I tried starting it and it turned over a while without starting and then suddenly it quit turning over at all. No click or anything.
      I charged battery and light turns on showing neutral and heatlight can go on.
      A few other things that may be pertinent: The pull start is missing, I have a fluke multimeter but not many other advanced tools (or relevant experience), there is an extra aftermarket led light attached to front but it doesnt work either... never looked into why since I didnt need it. 
      I looked for a fuse box and didnt find one.
      Please recommend some easier things to try first as I really want to avoid taking it in if I can (having one income and 4 kids can keep out extra cash, plus I want to learn). Pictures would be awesome if possible. Thanks! 
    • By Kanyon Pershing
      I have recently rebuilt my Yamaha warrior 350 engine and when I got it all back together with no “spare parts” i went to start it and realized it’s in reverse. I went to put it in drive and the shifter won’t budge, I took the linkage off and tried to use vise grips but it won’t budge at all. Any help would be greatly appreciated. I’m hoping it’s not something internal! 
    • By YamahaBB350
      I have a Yamaha Big Bear 350 and the reverse doesn’t work, it shifts from low to high easily but it won’t go back to reverse. I’m new to this stuff, so I’ll take any help. Any ideas? 
    • By oleskool
      Has new top end, piston, rings, valves, etc. great compression, good spark, plenty of fuel. Valves have been set. timing has been tripled checked. Can not get it to start. any ideas suggestions on anything I am missing. Also if anyone has the service manual it would be greatly appreciated.

      Thanks
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...