Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

cliffyh

2005 Grizzly 660 Backfiring and Incorrect Speed

Recommended Posts

Hi,

Have a 2005 grizzly 660. Just recently started backfiring and showing incorrect speed. Lifted seat and messed with wire going to starter relay, it stops for a bit but seems to come back.

I ended up pulling all the pins out of the connector for the relay and added new pin/connectors for all 4 wires. fixed it for a little bit but came back shortly after. This was a new starter relay i installed a few months ago. Anyone know if a bad starter relay would do this? 

Share this post


Link to post
Share on other sites


Hi @cliffyh I moved this out of the Yamaha Grizzly club forums to the main Yamaha ATV forums so more people would see it. Sounds like an electrical issue, is anything grounding out?

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Ajmboy
      Disconnected the plow yesterday on my 2004 Yamaha Grizzly 660 and am getting ready to do some riding yesterday and the battery went weak, Starter cranked a few times but week. Put my trickle charger on that I bought and went to the garage today to start it up, but the starter is just spinning and not engaging. The solenoid is clicking. The pull start sucks and is hard to pull (never use it and need to look into that). Quick video of the starter spinning. Could it be the starter or  the starter clutch one-way bearing? I guess I need to take the cover off to see what's going on.

      2004 Yamaha Grizzly 660 Starter Spinning.mp4
    • By JacobSlabach
      recently picked up some project bikes off CL for cheap.  got a honda fourtrax (the ancient 4x4 kind with the straight axle in the front as well as the rear and a back-up kick-start)  plastics are crap, but my goal is to get running like a champ and patch the plastics up and sell to one of my many friends that want a reliable 4x4 for dirt cheap and doesnt care what it looks like.
      so the former owner says it needs carb rebuilt, but its sat for 3+ years since so who knows.  things I see:  carb is missing (he gave me a box of parts along with the bike), engine turns over and feels good with kick-start, brakes need work, battery missing (That always puts me off, cause then I know most likely someone's been tampering with the electrical.
    • By ray desocio
      I posted earlier looking for a wiring diagram, but maybe someone can help me with the problem if they’ve had it before. 
       
      The quad Will start and idle ok, when I open the throttle it will rev all the way up until WOT and then it dies back down to idle, and if I keep the throttle wide open it will rev back up. It will do this over and over and over. 
       
      I replaced the carb, (twice), Rectifier, battery, and spark plug.  The Stator ohmed out to the proper specs from dinli.  The other issue i can see is I’m not getting 12v on the choke circuit. The lights don’t work either. 
       
      possible bad key switch? Maybe the new rectifier is bad? All the contacts on the key switch also ohm out properly    
      comprsssion is up to 125 psi and spark is there. 
       
      Reed valves look great.....
       
      im at a loss. Any trouble shooting advice would be appreciated. 
    • By Wayne Starz
      I have a 2005 Suzuki Vinson 500cc automatic 4X4. I can only shift it in to park & High gear, it will not go in low or reverse, what's the issue & the fix?
  • Similar Tagged Content

    • By Ajmboy
      Disconnected the plow yesterday on my 2004 Yamaha Grizzly 660 and am getting ready to do some riding yesterday and the battery went weak, Starter cranked a few times but week. Put my trickle charger on that I bought and went to the garage today to start it up, but the starter is just spinning and not engaging. The solenoid is clicking. The pull start sucks and is hard to pull (never use it and need to look into that). Quick video of the starter spinning. Could it be the starter or  the starter clutch one-way bearing? I guess I need to take the cover off to see what's going on.

      2004 Yamaha Grizzly 660 Starter Spinning.mp4
    • By Ajmboy
      Took the power washer and cleaner up the grizzly a bit.
    • By oxidized_black
      2002 Yamaha Grizzly 660 Service Manual
      View File 2002 Yamaha Grizzly 660 YFM660FWA Service Manual
      Submitter oxidized_black Submitted 12/15/2016 Category Yamaha ATV  
    • By oxidized_black
      2002 Yamaha Grizzly 660 YFM660FWA Service Manual
    • By Ajmboy
      This is more of an informational fix I wanted to share..
      My Grizzly has been getting harder and harder to shift this winter and today was completely stuck and I needed to plow the few inches that came down this morning. First thought...oh no, tranny...but it’s winter and maybe it’s iced up. I pulled off the plastic to see what was going on and indeed I did find the drain tube iced up. 
      I took the blow dryer out and de-iced it. Quick fix, I never really thought about the shifter drain tube icing up before, shifts like new!



      FA04AC3B-4FB0-4764-AFD9-1492F5CC790B.MOV
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...