Quantcast
Jump to content

CFMOTO Quadzilla CF800-2 Blown Fuse


spavin

Recommended Posts

  • Ajmboy changed the title to CFMOTO Quadzilla CF800-2 Blown Fuse

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By Werewolf
      Oil is getting in the air box from crankcase vent tube, I put the two hoses that go to the air box together then something started to smoke on the front of the engine. There is a filter? In the line I blew that out.
    • By semicolon
      Hi, I am having issues with my TRX350D fuel pump.  It suddenly stopped running so I have replaced all the fuses and cleaned all the terminals.  I have fitted a new pump, fuel cut-off relay and rectifier.  Still nothing!!  The pump runs when attached to a battery.  The engine will start on the choke and the filter fills with fuel but it will  not rev and dies when the choke is closed. I have power to the relay but nothing at the pump black/white wire when cranking the engine.  Any ideas where to go from here would be very much appreciated!!
       
    • By NZrider
      My king quad 700 runs rough when cold then won't start some times but not often when it's hot. And occasionally smoke's a lot when it's cold I'm guessing that's rings but I'm worried unless it's causing the other problems
       
       
       
      All help is appreciated thanks
    • By Suzukiquad
      If you had to choose one mod that you couldn't live without, or had to recommend one what would it be? 
    • By bighoss
      i got my son new outlaw 50 a few weeks ago and we went rideing yesterday and while we were riding it died and it took me like 10 min to get started back and it died agen when we got close to truck so i pulled it back took the plug out it looked like it was drop in a bucket of gas took the air filter out and the ait box was full of gas also got home it started rite up today i started it it starter up but was blowing what look like water out of the exholst let it idel for a lil bit did not die but as soon as hit the gas and let off it will die what does that sound like i thnk i going to take it back to dealer and tell them to fix it as it is under warrenty but would like to know what it could be first
×
×
  • Create New...