Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

1998 Suzuki King Quad 300 Front Brake Shoe part #


Recommended Posts

 

Hi,

Oddly I'm having  a hard time ordering front brake shoes for my '98. 

I'd appreciate recommendations on decent, widely available shoes if possible. Ideally available in Canada on short notice.

 

Thanks much,

 

Warren

Link to post
Share on other sites
  • Ajmboy changed the title to 1998 Suzuki King Quad 300 Front Brake Shoe part #


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Tagged Content

    • By smitht18
      Looking for the rectifier.  Most bikes have near magneto.  It appears the KQ has it in front.
      Can someone tell me exactly where it is? 
      Bike not charging and magneto checks out ok
    • By Jodawg1981
      Need a cdi box for a 93 king quad suzukie 300 4wd. If you got one olease message asap. Cash waiting
    • By Jodawg1981
      So i got this from my boss. It sat for a long time. I cleaned the carb, had it running for 2 weeks with no issues.then this past saturday it shut off after riding for a while. Tried to start and it went to smoking. Fried the harness. Well thru the week i repaired and rewired the harness and got it back running. Now when u give it throttle it either bogs down bad or starts to backfire. It never did that before the melt down. Trying to figure out what is going on and its driving me crazy. Any ideas?
    • By LOGAN WARNER
      Hello everyone, I’m new to this forum. I have a 98 king quad 300, I cannot get it to run right. It will start up and run for a little bit but then it starts sputtering when you give it throttle. It appears to me that it is getting to much fuel. 
      this is what I have done to it: new carburetor, new fuel filter, adjusted the valves.
  • Similar Topics

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...