Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Bebe

1988 yamaha warrior intermittent spark

Recommended Posts

Hey guys I'm new here. I have a 88 warrior that has intermittent spark. When I got the bike the guy said it needed a stator.  So I tested the stator and the Source coil has .310,  Trigger coil has .363 an .367,  Alternator side has .05 to .06 on the three. Which all seem in range. I did find that the ignition coil was bad and replaced it. After I  put the new coil on i got spark but only now and then. The bike won't spark while I'm holding the start button,  but as soon as I let off it will spark sometimes. I ended up unplugging the voltage regulator and it will spark every time I let off the start button, but still will not spark while I'm  holding it. What could this be?

 

Share this post


Link to post
Share on other sites


Most likely CDI.  Normally when you get spark when releasing the start button that's not actual spark but instead is residual voltage bleeding off from the starter circuit.  You can always try baking the CDI for 5 minutes or so at 250 and see if it'll start then.  CDI's usually go bad when the ceramic in the capacitor gets cracked and it gets a bit of moisture.  If it'll start after that, you know it's the CDI and time to get a new one.  Don't buy the cheap $30 chinesium one though, those are only about 2 out of 10 good new in box.

Share this post


Link to post
Share on other sites

That makes sense with the residual voltage. I tried baking the cdi today and nothing changed. Do you have any suggestions on which is a good company to get a new CDI box from?

Share this post


Link to post
Share on other sites

Rick's CDI is the best for Honda by a mile, maybe google and see if there is one for yours? Otherwise good 2nd hand OEM from ebay or new if still available on Partzilla, Babbitts etc. The chinese cheap ones are just terrible. I've had good luck with good 2nd hand OEM parts on ebay. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Spike976
      So I dug my warrior out of storage replaced the carburetor with one off Amazon & it was running great. Last week it didn't want to start it would crank & I could smell gas but nothing. I replaced the starter,stator,solenoid,spark plug & coil & resistor but still not starting. Checked the stator and its at 30 ohms tried using starter fluid but nothing. I am completely lost and could use some help thank you
    • By Nick Gudex
      Hello I am new to this site and I havea problem. I have a 1987 big bear 4x4 that will not spark. I tested pick up coil per repair manual and I tested my new coil both ok. It puts out 9 volts at the coil but It is reversed polarity. So when I hook my meter up to it she shows -9 volts while cranking. When I put a test light  on it it flashes. Being an electric system this should tell me something but I don't know what its telling me. I have yet to meet one i could not fix but this old girl has me stumped. Any help would be awesome. Thanks to all.
      Nick
    • By Gary Mier
      1997 Yamaha 350 Warrior, should there be oil in the stator area? Have a no spark situation.
    • By Brent Mason
      1998 Grizzly600 ! Slowly died then wouldn’t start ! All coils check good ohms ! Checked ac voltage from source coil get OL ! Is the source coil bad ? 
    • By Jerry Hebert
      1985 Lt50 no spark from aftermarket coil . Are these Suzuki coil specific ??
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...