Quantcast
Jump to content

Plow for bayou


Sketchy

Recommended Posts

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By hardcastle
      My friends KQ 300 starts fine and runs, as soon as you put it in gear and try to accelerate its bucks and farts like crazy, not moving... I cleaned carb and it worked good for 1 day... now back to same problem.... could it be such as a bent valve????
    • By skittle021
      So I've got a Hisun 550 that I was doing some work on that required removing the CVT and it's housing. Upon attempting to reinstall the clutch, sheaves, etc, I found that the belt no longer fits - it's far too wide. None of the parts have been replaced, they're all OEM. Exactly the same parts as what I took off a few weeks ago.
      To be more specific, my belt is 1.25in wide, but the gap between the clutch and the primary sheave is only 7/8in wide. I'll include a few photos to explain.
      Has anyone ever experienced such a bizarre problem? Any help at all would be appreciated, I've been stuck on this for a month. I'm open to just about any suggestion.
      Photos: 
       





    • By Louznmemind
      Howdy y'all, I'm trying to fix a neighbors 2015 Brute Force 300. Came in with hard to start and won't idle except on choke issue. I pulled the carb and found the pilot jet as well as the emulsion tube partially clogged. Cleaned up everything, put it back together, still having issues...  It will start right up on choke and will also start off choke if you give it just a touch of throttle but it absolutely will not idle unless it's choked just a touch. Also, excuse my ignorance but I'm assuming the "dial" thingy attached to the carb that turns in and out is for setting idle?? 
    • By Its-always-something
      Have a 1998 AC 300 2x4, Just installed a new carburetor. Engine starts easy but the choke RPMs are very hi and take along time (5-10 mins when cold out). After engine has warmed up choke releases and it idles and runs fine., It does no have an electric choke. The choke lever is never used and it seems like an auto choke? Long story short, how can I lower the choke rpm levels?
       
      Also, carb came with a spare145 jet, not 100% sure what is installed. Could this impact choke RPMs?
       
       
      Any help and information greatly appreciated.
    • By Charlesbrown
      I’m looking for a top end kit for a Yamaha. I would like to see how well the engine runs before spending $6-$7 hundred on oem. Niche has complete kits from $1-$2 hundred.  Anyone have experience with Niche or similar Chinese companies? 
×
×
  • Create New...