Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    Join QUADCRAZY ATV Forum today for FREE! We keep these forums clean and user friendly. All first posters will have to wait to have their content reviewed and approved. Once your first post is approved, you will no longer need to got through an approval process. To gain immediate approval and a NO ADS experience, consider subsribing to our Premium Membership.

Funny quad pics.


zacdog
 Share

Recommended Posts

  • 3 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Topics

    • By Kidshavebrokeme
      Hello, Im looking for some help instead of spending hours on You Tube. Got roped in to buying the above Kazuma 110 I think. I've worked on all brand of autos.
       thought I could tackle this butttt. No start no spark. My stator is producing a faint light by ground. Buy the meter I get 337 ohms on the 
      black, red wire. Some of my questions, Can I bypass everything to look for spark. Can the plunger type kill switch be removed an both wires put 
      together to help achieve spark that is behind the seat. My black red to the cdi has no power to it when turning over. Should i put some form of 
      lubricant in the plug hole or are these motors moving the oil enough and should the plug be in or out or does it matter when looking for spark?
      I'm thinking the wire for the coil from the cdi should light up the test light and it does not. (Forget its color at the moment). I hope there's not a limit
      of questions cause i will have more and Im not much for typing. Any help would be just jim dandy and greatly appreciated. Thanks Steve
    • By Yammy
      Can you ride your quad on the road or cross a road if your quad is licensed and registered and you have functional signal lights and running lights?
      Let me know, I'm new to this.
      Thanks! 
    • By KansasKodiak
      So got my Quad and in a matter of four weeks it's proved a game changer in my hunting prep. I used it to haul all the material to build a suspension bridge across the creek in the back of my property. That creek is a ankle deep trickle mostly except when it rains and then its up to my waist or higher. Kinda limits access during rain. Secondly iI hauled all my stands, climbing sticks and equipment out using the quad. So nice to have the mechanical muscle now. 
    • By kxpro8012345
      Hi All,
      I have a 1992 Suzuki King Quad 300. I got it in rough, picked apart condition on Facebook marketplace. The previous owner was not mechanically inclined and threw parts, and deleted parts to get this to "run". To give you an idea of what I am dealing with he put a non vacuum carb on with a separate fuel bladder mounted on the rear rack. I live in CT and things are a bit high here so I got the atv with a plow for $400. The atv came with (3) Carbs, 1 OEM, (2) petcocks 1 OEM. What I have done / found is the neutral safety switch was ate by mice (probably the original problem), fixed that, reinstalled (cleaned and put in a new needle and seat) OEM carb, the diaphragm is a little clapped out but still flexible, installed new Fuel pump, cleaned and reinstalled OEM petcock (non vacuum) has slight drip every now and again as I did not replace the tank side gasket when I installed and installed a brand new battery.  doing all that the quad fires and runs but briefly.  On the handle bar the choke paddle is broke off, I ordered that and looks like you need to remove the grip to install so haven't done yet and If i can get some direction on that as well, So that is "floating" in  the carb as I do not have the correct choke cable connector, I took the one off the Chinese carb and it somewhat holds it in place. The air box and system are gone and it has a stubby K&N cone filter on it currently.  So the way I start it is pop off the air filer, hold my hand over the carb to get a good enough vacuum to get to the bowl, then it will run for a few seconds. The tank is filled to the top, to help it out. Does anyone think I am missing anything before purchasing the entire air box system (If I can find it). This will be a yard machine for work and will not be taken out recreationally, cool little machine I would like to keep it, but unsure if I will spend the money on a airbox system as it for sure seems I am not pulling a good enough vacuum with out it. 
    • By Valkman
      Hey all, new to the forum.  I just bought a 2001 King Quad, and the clutch is slipping. I adjusted the play with no improvement, so before I go through the trouble of replacing the clutch disc, I want to see if motor oil in it is the problem.  My question is Rotella T4 ok to use? I run in my motorcycles with no issues but I thought I'd get your input.
  • Similar Tagged Content

  • Gallery Images

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...