Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
utvboard

Arizona Dirt Sand Expo Combines with Arizona Motorcycle Expo For One Big Event in De

Recommended Posts

PHOENIX, AZ – SEPTEMBER 15, 2009: The Arizona Dirt Sand Expo has combined with the Arizona Motorcycle Expo at the Arizona State Fairgrounds for one big show the weekend of December 12th and 13th. With the economic state, the promoters AZ Expos, Inc have changed the structure from a formal show to a SuperSwap with very affordable $100 booth prices. AZ Expos goal is to provide companies the

More...

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By CJ River Rider
      Anybody know whatever happened to this?
    • By Tim-ANC
      Had the problem earlier this month. Found the air intake filter (K&N) covered in mud and cleaned it. Took it out this weekend and it worked great until I went on a longer ride.
       
      After it warms up, it bogs down at about 20mph. Engine sputters. No change at full throttle. It runs fine at lower RPM. Once it cools off, I can run it at higher speed for a few minutes then it bogs down. Seems like there is an electronic component that overheats. Check engine display comes on when it happens. Did manage to complete our 34 mile ride though.
       
      Buddy suggested the throttle position sensor. Will dig into the manual later on.
       
       
       
       
       
       
    • By colin james
      View File 2006 Polaris Sawtooth 200 & Phoenix 200 Service Manual
      This is the service manual for 2006 Polaris Sawtooth 200 & Phoenix 200 ATVs. Download all the chapters for the complete manual. 
       
      Submitter colin james Submitted 11/25/2018 Category Polaris ATV  
    • By Redneckracing14
      I currently live in indiana i have 2 atvs that are titled and registered in indiana i want to take them to kentucky to do trail riding buti want to do to it perfectly legal do i need to register it in the state of Kentucky to and will the permit at whatever place im riding at cover me ive looked all over net cant really find a answer thanks
  • Similar Tagged Content

    • By William Waterworth
      I dont really know much about working on quads, just go off of manuals and luck. I recently got a 1987 Moto 4, YFM350ERT that could use some work. Is there or does anyone know a mechanic in Phoenix, Arizona that might be able to take a look. Be able to tell me what it all needs and basically a diagnostic that wont break the bank. Any advice would be appreciated
    • By mallen14
      Looking for anybody who can point me towards a free service manual for 1998 Big Bear 350. I found the sticky thread but all the links, from 2012, no longer work. If anybody has one please let me know. Thanks
    • By dctaz37
      My ATV started making a rubbing and clunking noise. I took the skid plates off and found that the front u-joint on the shaft that connects the front axle to the transfer case is toast. My manual does not reference this repair. Looking for instructions.
    • By Barrysquad
      Somehow I lost all of my spark on my 350Big Bear, its a 1990. It ran well for maybe 3 days! Thought it was the carb. Cleaned it 4 times. It was losing power at midrange. Got worse and worse. Finally nothing!
      Are these good coils? I was thinking I could swap?
      2002 Honda-200cc: primary 0.4(ohm-200) secondary 9.0(ohm20k)
      1990 Yamaha-350cc: primary 0.8 secondary 11.0
    • By dboy910
      Ok new to group and new to quads. I picked up a 88 Big Bear for next to nothing but it has issues. The entire high low revers shifter has been removed. All I have is a bar attached to the linkage. I can shift into all three but I would like to replace or get suggestions. I have looked around but there is limited info or pictures on what I would need to buy or where it even mounts. Any pics of what where and how it works would be great. Or direct me to correct thread.
      Thanks
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...